Bug 1302339 - [PATCH] Fix build on illumos
[PATCH] Fix build on illumos
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libosinfo (Show other bugs)
unspecified
x86_64 Solaris
unspecified Severity high
: ---
: ---
Assigned To: Zeeshan Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 09:21 EST by Andrew Stormont
Modified: 2016-09-19 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 09:58:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes build on illumos (356 bytes, patch)
2016-01-27 09:21 EST, Andrew Stormont
no flags Details | Diff

  None (edit)
Description Andrew Stormont 2016-01-27 09:21:39 EST
Created attachment 1118793 [details]
Fixes build on illumos

Description of problem:
Build blows up on illumos because the linker is passed arguments it doesn't like.


Version-Release number of selected component (if applicable):
0.3.0


How reproducible:
Build on illumos


Steps to Reproduce:
1. configure
2. run make
3. weep

Actual results:
Build fails


Expected results:
Build fails (everything fails to build on illumos)

Additional info:
Fix is attached
Comment 1 Fabiano Fidêncio 2016-05-11 09:58:52 EDT
Thanks for the patch. It's applied (587b7a624c15cf585ab3885a37609a31cd028d67) and will be part of 0.3.1. release.

Note You need to log in before you can comment on or make changes to this bug.