Bug 1302346 - Self-compiled kernel hangs at boot
Summary: Self-compiled kernel hangs at boot
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-27 14:38 UTC by Patrick Proche
Modified: 2016-01-27 14:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-27 14:49:41 UTC


Attachments (Terms of Use)

Description Patrick Proche 2016-01-27 14:38:51 UTC
Description of problem:
When booting a kernel which was compiled under FC23 from a source from kernel.org, the boot process hangs.
Version-Release number of selected component (if applicable):


How reproducible:
Always (but please see description)

Steps to Reproduce:
1. I download the kernel source, for example 4.4, from kernel.org, unpack it, configure it, compile and install it.
2. Booting this kernel hangs, the last message on the screen is about remote file systems.

Actual results:
Boot hangs forever.

Expected results:
Machine should boot.

Additional info:
Seemingly any self-compiled kernel hangs at the boot process. I could not find any logs in /var/log/messages why the boot process stops.

WHY DO I FILE THIS HERE:
I upgraded my Lenovo E330 laptop from FC20 to FC23 (FC20->FC21->FC22->FC23) with fedup several days ago. I had several self-compiled kernels on the machine - compiled under FC20, so BEFORE the upgrade - which all boot(ed) and worked fine BEFORE and AFTER the upgrade. But if I compile a kernel from the same source with the same configuration under FC23 - AFTER the upgrade, the boot hangs (always).

I happily provide any log files if you tell me how to obtain them. I could not find anything in my /var/log/messages.

I tried with several kernel sources, but no difference.

Comment 1 Fedora Kernel Team 2016-01-27 14:49:41 UTC

*** This bug has been marked as a duplicate of bug 126342 ***


Note You need to log in before you can comment on or make changes to this bug.