Bug 1302356 - Storage domain export path does not support [IPv6]:/path input
Storage domain export path does not support [IPv6]:/path input
Status: CLOSED DUPLICATE of bug 1302358
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 10:20 EST by Edward Haas
Modified: 2016-02-01 05:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 12:31:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Edward Haas 2016-01-27 10:20:40 EST
Description of problem:
When creating a new Storage Domain, the export path cannot be edited with an IPv6 address.
The format should be [IPv6 Address]:/path, e.g [201::1]:/path

Version-Release number of selected component (if applicable):
Latest

How reproducible:
Try to add a new storage domain with an IPv6 address/

Steps to Reproduce:
1. Open Storage tab.
2. Click New Domain
3. Edit in 'Export Path' textbox something like: [201::1]:/my/folder
4. Try to add the domain.

Actual results:
Error on the textbox: NFS mount path is illegal...

Expected results:
To accept the address and connect to the storage.

Additional info:
Should work with all storage types.
It is part of the IPv6 task.
With an FQDN that points to an IPv6 address, it works fine.
Comment 1 Tal Nisan 2016-01-31 12:31:47 EST

*** This bug has been marked as a duplicate of bug 1302358 ***

Note You need to log in before you can comment on or make changes to this bug.