Bug 1302361 - Add recommendation to utilize mkfs.xfs defaults to prevent poor performance and/or behavior
Add recommendation to utilize mkfs.xfs defaults to prevent poor performance a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.0
All Linux
medium Severity medium
: rc
: 1.3.3
Assigned To: Aron Gunn
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 10:39 EST by Kyle Squizzato
Modified: 2016-09-30 13:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-30 13:22:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1597523 None None None 2016-01-27 10:39 EST

  None (edit)
Description Kyle Squizzato 2016-01-27 10:39:01 EST
Description of problem:
Add a recommendation bullet point under "CHAPTER 14. ADD OSDS" which suggests using the mkfs.xfs defaults employed by ceph-deploy.  Possibly include a note which states that using non-defaults could result in poor behavior. 

Additional info:

This is to combat customers changing away from the defaults used to format OSDs and encountering bugs in their environments at a later date.  For example, a customer encountered https://bugzilla.redhat.com/show_bug.cgi?id=1278992 when they set '-n 65536' on their OSDs, which is a bug that is entirely due to them using such a high directory block size that is non-default.

While the high directory size issue is a bug in XFS, it is a complicated fix which may take a long time before making it into the RHEL code base.  We can try to prevent further customers from hitting this issue by mentioning this in the Ceph documentation.
Comment 5 Joseph Kachuck 2016-06-14 15:42:20 EDT
May HPE have access to this BZ?

Thank You
Joe Kachuck

Note You need to log in before you can comment on or make changes to this bug.