Bug 1302366 - soup_headers_parse: deal with NUL bytes in headers
soup_headers_parse: deal with NUL bytes in headers
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libsoup (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Milan Crha
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 10:53 EST by Milan Crha
Modified: 2016-11-03 22:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: libsoup-2.48.1-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 760832 None None None 2016-01-27 10:53 EST

  None (edit)
Description Milan Crha 2016-01-27 10:53:18 EST
The Yahoo! server has some issue, it passes headers in a way which is not fully correct and the libsoup library rejects it with a Message Corrupt error. This is discussed in an upstream bug report [1]. It also contains a fix, which can be easily backported.

This issue blocks evolution-data-server users to connect to Yahoo! calendars, which are added when user creates a Yahoo! mail account from within the evolution.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=760832
Comment 4 errata-xmlrpc 2016-11-03 22:48:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2289.html

Note You need to log in before you can comment on or make changes to this bug.