Bug 1302394 - [RFE] make sure no tasks are running before starting Satellite upgrade
[RFE] make sure no tasks are running before starting Satellite upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.6
Unspecified Unspecified
medium Severity medium (vote)
: GA
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged, UserExperience
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker 1122832
  Show dependency treegraph
 
Reported: 2016-01-27 12:46 EST by Peter Vreman
Modified: 2016-11-18 11:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 09:42:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vreman 2016-01-27 12:46:54 EST
Description of problem:
When there are pending tasks in the background and the upgrade is started the upgrade might fail and the user has a complex recovery process to fix all aborted tasks and also the upgrade process in katello-install upgrade might not run until the end because of conflicting tasks


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start RedHat sync of 50 channels
2. Start Content View publishing with 30.000+ packages
3. Start the katello-installer --upgrade

Actual results:
- Conflicting tasks preventing upgrade process to finsihed successful
- Aborted tasks after upgrade
- Complex recovery process similair to https://access.redhat.com/solutions/1381053


Expected results:

The katello-installer shall only start the upgrade when no pending tasks are running. The user shall wait for tasks to finsih or stop them manual first.

The katello-installer shall put Sat6 in a global 'suspended' state that no new tasks are started during the upgrade


Additional info:
Comment 2 Brad Buckingham 2016-04-08 11:33:32 EDT
Note: during triage, it was also discussed to check for paused tasks.
Comment 3 Bryan Kearney 2016-07-08 16:41:15 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Stephen Benjamin 2016-10-14 09:42:22 EDT
In 6.2.0, we introduced the pre-upgrade check script which includes this.

See: https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/installation-guide/#upgrading_satellite_server 2.b.:


     "Run the pre-upgrade check script to get a list of hosts that can be deleted after upgrading. If any unassociated hosts are found, associating them to an organization before upgrading is recommended.

    # foreman-rake katello:upgrade_check

    If the upgrade check reports a failure due to running tasks, then it is recommended that you wait for the tasks to complete. It is possible to cancel some tasks, but you should follow the guidance in the Red Hat Knowledgebase solution How to manage paused tasks on Red Hat Satellite 6 to understand which tasks are safe to cancel and which are not safe to cancel. "



Thanks!

Note You need to log in before you can comment on or make changes to this bug.