This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130240 - nifd service is not added using chkconfig during package installation.
nifd service is not added using chkconfig during package installation.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: howl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-18 09:54 EDT by Alistair Riddoch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 07:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alistair Riddoch 2004-08-18 09:54:01 EDT
Description of problem:

nifd service is not added using chkconfig during package installation.

Version-Release number of selected component (if applicable):

0.9.6-1

How reproducible:

Always.

Steps to Reproduce:
1. Install howl 0.9.6-1 from rpm.
2. Attempt to use chkconfig to view or control the nifd service.
3.
  
Actual results:

chkconfig does not know about nifd service.

Expected results:

chkconfig should be able to list the nifd service, and allow the
administrator to turn the service on or off.

Additional info:

Looking at the spec, it is clear that init scripts for both services
are installed in /etc/init.d, but chkconfig --add is only used on the
mDNSResponder service. In order for the nifd service to be available
to the standard service management tools, chkconfig --add should also
be used on the nifd service.
Comment 1 Alexander Larsson 2004-09-01 08:03:15 EDT
Its not installed because autoipd isn't really integrated into the os
yet (and i'm not sure yet exactly how to do this in the best way). So,
nifd isn't needed.
Comment 2 Alistair Riddoch 2004-09-01 08:40:47 EDT
It seems confusing for the init script to exist in /etc/rc.d/init.d
but not be registered using chkconfig. It seems like it would make more
sense for it to be registered, but default to off, or remove the
script from the package for the time being while it is not usable.
Comment 3 Alexander Larsson 2004-09-14 07:57:58 EDT
Fixed in 0.9.6-3

Note You need to log in before you can comment on or make changes to this bug.