Bug 1302411 - Docker 1.9 has issues assigning IP addresses correctly
Docker 1.9 has issues assigning IP addresses correctly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 13:57 EST by Andy Goldstein
Modified: 2016-03-31 19:23 EDT (History)
9 users (show)

See Also:
Fixed In Version: docker-1.9.1-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:23:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Weibin Liang 2016-01-29 13:27:16 EST
I tried this with a loop in my simple script to create and remove three containers in docker version 1.9.0 and 1.9.1, but i still can not reproduce it.

This morning I tried the latest Package version: docker-1.9.1-15.el7.x86_64, I still can not see the issue.

[root@dhcp-41-11 tmp]# docker version
Client:
 Version:         1.9.1
 API version:     1.21
 Package version: docker-1.9.1-15.el7.x86_64
 Go version:      go1.4.2
 Git commit:      50e78a0/1.9.1
 Built:          
 OS/Arch:         linux/amd64

Server:
 Version:         1.9.1
 API version:     1.21
 Package version: docker-1.9.1-15.el7.x86_64
 Go version:      go1.4.2
 Git commit:      50e78a0/1.9.1
 Built:          
 OS/Arch:         linux/amd64
[root@dhcp-41-11 tmp]#
f92903a55bf2650ed084c9928533514920f98dfe45d6d069daea4d8a99563d54
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
myweb
7a0c4868252a981b77b7b469b19a4a588d1588454f86af0c580ee9444999975b
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
b55d0cac2ef31e6900f03afd8071884840a5b8f33f1aad11e24a6f8225c67929
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
myweb
72bb773960fc112c7b88c7f89d2ad87cb7bc8c03636724437a167fa08061ee3f
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
myweb1
c3b305b1db171a607ce7ced1b3b7657ffeceea575c12983fb5078cd4eec1e94c
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
myweb
myweb1
4b5d1b5f4d1d3f1d1732454cfab7620b0873fa61502b4c18c6980f595a833456
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
1257d5e1319342138c1cb3e5605c4b30b4d5d7b76b9ac568a6e45fbdbb8d0c28
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
4dc3098659fa8720f9d41fc7d711d824aabbdb9743d7980d24754a0d0a23245b
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
172.17.0.4
myweb2
fbb0a430aab26e1a9b9e750aba6e5c6309b3128679660956668c26a79d668208
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
172.17.0.2
172.17.0.3
172.17.0.4
Comment 6 Luwen Su 2016-03-17 13:48:24 EDT
In docker-1.9.1-23.el7.x86_64, same as comment#5, i started 100 containers and remove them, not meet this issue, move to verified
Comment 8 errata-xmlrpc 2016-03-31 19:23:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0536.html

Note You need to log in before you can comment on or make changes to this bug.