Bug 1302425 - script doesn't stop in bulk mode
script doesn't stop in bulk mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap (Show other bugs)
6.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Frank Ch. Eigler
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 15:23 EST by Martin Cermak
Modified: 2016-05-10 17:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: systemtap-2.9-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 17:11:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 19525 None None None 2016-01-27 15:24 EST

  None (edit)
Description Martin Cermak 2016-01-27 15:23:22 EST
Following script running in bulk mode under systemtap-2.9-1.el6 never stops (regression compared to systemtap-2.7-2.el6):

stap -be 'probe begin { log("hey") exit() }'

caused by upstream commit 62d2a73ee995 (PR19525).
Comment 4 errata-xmlrpc 2016-05-10 17:11:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0823.html

Note You need to log in before you can comment on or make changes to this bug.