Bug 1302427 - [RFE] Add ability to import RHEL KVM guest images (managed by libvirt) directly into RHEV
[RFE] Add ability to import RHEL KVM guest images (managed by libvirt) direct...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.5.0
All Linux
high Severity medium
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Shahar Havivi
Nisim Simsolo
http://www.ovirt.org/develop/release-...
: FutureFeature
Depends On: 1342133 1359668
Blocks: 1276215 1386828 1406229
  Show dependency treegraph
 
Reported: 2016-01-27 15:38 EST by Derrick Ornelas
Modified: 2017-06-22 15:04 EDT (History)
17 users (show)

See Also:
Fixed In Version: 4.0.0-12
Doc Type: Enhancement
Doc Text:
With this update, the ability to import Red Hat Enterprise Linux KVM guest images managed by libvirt directly to Red Hat Virtualization has been added. To import KVM virtual machines from libvirt the libvirt uri, username and password are required. For the libvirt uri using QEMU and TCP is qemu+tcp://[USER]@[HOST]/system. QEMU and ssh is also supported but requires that the VDSM user is enabled and public/private keys must be generated for the VDSM user and exhanged with the libvirt server.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:32:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: testing_plan_complete?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2712251 None None None 2016-10-27 00:27 EDT
oVirt gerrit 51286 None None None 2016-01-29 06:41 EST
oVirt gerrit 55797 None None None 2016-05-11 01:11 EDT
oVirt gerrit 56459 None None None 2016-05-11 01:11 EDT
oVirt gerrit 56531 None None None 2016-05-11 01:12 EDT
oVirt gerrit 56912 None None None 2016-05-11 01:12 EDT
oVirt gerrit 57247 None None None 2016-05-11 01:11 EDT
Red Hat Product Errata RHEA-2016:1743 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 17:54:01 EDT

  None (edit)
Description Derrick Ornelas 2016-01-27 15:38:02 EST
Add ability to import RHEL KVM guest images directly into RHEV 

As of the latest version of libguestfs/virt-v2v there is no support for converting virtual machines running on RHEL KVM and copying them to a RHEV Export storage domain.  The feature was removed from libguestfs because no conversion is needed inside a guest already running on QEMU/KVM, and it was feared that the intrusive nature of the conversion process was an undue risk.  This decision means there is no supported way to get a RHEL KVM guest into a RHEV environment.  

Add an Import option to the RHEV UI that take RHEL KVM host information, connects to the host, lists guests, and allows the user to select with VM(s) to import.  The import should extract the VM info, create VM , create vdisk(s), and then copy disk image(s) to desired Data storage domain(s).
Comment 3 Michal Skrivanek 2016-01-29 06:41:02 EST
note the scope of this feature is libvirt-based guests. Not plain disk files, nor "loose" qemu processes.
Comment 4 Moran Goldboim 2016-03-24 06:40:04 EDT
postponing to next version due to capacity reasons.
Comment 5 Yaniv Lavi 2016-05-05 10:00:32 EDT
Is this going to be in 4.0 or not? I see the patch is progressing.
Comment 6 Shahar Havivi 2016-05-05 10:36:30 EDT
Looks its going to make it
Comment 7 Yaniv Lavi 2016-05-05 11:18:05 EDT
should we move this back?
Comment 11 Nisim Simsolo 2016-08-22 04:03:43 EDT
Verified: 
rhevm-4.0.2.6-0.1.el7ev
libvirt-client-2.0.0-5.el7.x86_64
vdsm-4.18.11-1.el7ev.x86_64
qemu-kvm-rhev-2.6.0-21.el7.x86_64
sanlock-3.4.0-1.el7.x86_64

polarion test plan added to external trackers.
Comment 13 errata-xmlrpc 2016-08-23 16:32:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.