Bug 1302432 - qpid-cpp-server and qpid-cpp-client have broken dependencies in Rawhide
qpid-cpp-server and qpid-cpp-client have broken dependencies in Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 16:28 EST by Randy Barlow
Modified: 2016-01-28 12:08 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 12:08:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-01-27 16:28:41 EST
$ sudo dnf upgrade qpid-cpp-client qpid-cpp-server
Last metadata expiration check performed 0:40:58 ago on Wed Jan 27 15:45:14 2016.
Dependencies resolved.
=====================================================================================================================
 Package                             Arch                 Version                        Repository             Size
=====================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 boost                               x86_64               1.60.0-2.fc24                  rawhide                46 k
 boost-atomic                        x86_64               1.60.0-2.fc24                  rawhide                48 k
 boost-chrono                        x86_64               1.60.0-2.fc24                  rawhide                55 k
 boost-context                       x86_64               1.60.0-2.fc24                  rawhide                60 k
 boost-coroutine                     x86_64               1.60.0-2.fc24                  rawhide                61 k
 boost-date-time                     x86_64               1.60.0-2.fc24                  rawhide                61 k
 boost-filesystem                    x86_64               1.60.0-2.fc24                  rawhide                76 k
 boost-graph                         x86_64               1.60.0-2.fc24                  rawhide               141 k
 boost-iostreams                     x86_64               1.60.0-2.fc24                  rawhide                70 k
 boost-locale                        x86_64               1.60.0-2.fc24                  rawhide               283 k
 boost-log                           x86_64               1.60.0-2.fc24                  rawhide               436 k
 boost-math                          x86_64               1.60.0-2.fc24                  rawhide               316 k
 boost-program-options               x86_64               1.60.0-2.fc24                  rawhide               168 k
 boost-python                        x86_64               1.60.0-2.fc24                  rawhide               136 k
 boost-random                        x86_64               1.60.0-2.fc24                  rawhide                53 k
 boost-regex                         x86_64               1.60.0-2.fc24                  rawhide               305 k
 boost-serialization                 x86_64               1.60.0-2.fc24                  rawhide               152 k
 boost-signals                       x86_64               1.60.0-2.fc24                  rawhide                73 k
 boost-system                        x86_64               1.60.0-2.fc24                  rawhide                51 k
 boost-test                          x86_64               1.60.0-2.fc24                  rawhide               246 k
 boost-thread                        x86_64               1.60.0-2.fc24                  rawhide                92 k
 boost-timer                         x86_64               1.60.0-2.fc24                  rawhide                52 k
 boost-type_erasure                  x86_64               1.60.0-2.fc24                  rawhide                61 k
 boost-wave                          x86_64               1.60.0-2.fc24                  rawhide               229 k
 libquadmath                         x86_64               5.3.1-3.fc24                   rawhide               179 k
 qpid-cpp-client                     x86_64               0.34-6.fc24                    rawhide               1.2 M
 qpid-cpp-server                     x86_64               0.34-6.fc24                    rawhide               1.6 M

Transaction Summary
=====================================================================================================================
Skip  27 Packages

Nothing to do.
Complete!
Comment 1 Brian Bouterse 2016-01-27 17:18:38 EST
I missed it with the first read through, but the clue is output saying "Skipping packages with conflicts" and then "Skip 27 Packages".
Comment 3 Jonathan Wakely 2016-01-28 10:52:12 EST
qpid-cpp was rebuilt last week to use the new Boost:

http://koji.fedoraproject.org/koji/buildinfo?buildID=711764

If there are conflicts then it's because something else can't be upgraded because it still needs the old boost, in which case the "something else" needs to be rebuilt in rawhide.
Comment 4 Jonathan Wakely 2016-01-28 11:55:57 EST
I've just cleanly installed boost and qpid-cpp on a fresh rawhide installation, so the problem is definitely not with either of those packages, but something else that depends on Boost.

I don't know how to get DNF to tell you what the problem is, it's quite annoying like that.
Comment 5 Jonathan Wakely 2016-01-28 11:59:16 EST
You could try --best --allowerasing and see which packages it attempts to erase. It will be one of the packages listed at:
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/QAQZTHXSTXS4VWCO3SH7BCEY5QYDMCB5/

The bug should be reported against that package, so the maintainer fixes the build failure and rebuilds it.
Comment 6 Randy Barlow 2016-01-28 12:08:34 EST
Whatever it was, the issue seems to have been resolved between yesterday and today because I can now upgrade. Thanks to mystery packager!

Note You need to log in before you can comment on or make changes to this bug.