Bug 1302446 - [RFE] Project request quota admission control
[RFE] Project request quota admission control
Status: CLOSED DUPLICATE of bug 1297320
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Cesar Wong
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 17:36 EST by Ryan Howe
Modified: 2016-05-18 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-18 16:34:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2016-01-27 17:36:58 EST
Description of problem:

 Looking for the ability to limit the number of projects of a user. This RFE is to monitor the upstream PR. 


Additional info:

https://github.com/openshift/origin/pull/6768
Comment 2 Eric Rich 2016-05-18 16:34:00 EDT
This seems to have shipped with 3.2 https://docs.openshift.com/enterprise/3.2/architecture/additional_concepts/admission_controllers.html

In short this feature is covered by the https://docs.openshift.com/enterprise/3.2/admin_guide/managing_projects.html, https://docs.openshift.com/enterprise/3.2/dev_guide/projects.html

Focus should be given to https://docs.openshift.com/enterprise/3.2/admin_guide/managing_projects.html#modifying-the-template-for-new-projects to set pod/build limits for the project, in addition to simply setting the number of projects uses can have.

*** This bug has been marked as a duplicate of bug 1297320 ***

Note You need to log in before you can comment on or make changes to this bug.