Bug 1302464 - Update to mbedtls causes a dependency issue with pdns
Update to mbedtls causes a dependency issue with pdns
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: pdns (Show other bugs)
epel7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Morten Stevens
Fedora Extras Quality Assurance
:
: 1303343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 19:04 EST by Boden Garman
Modified: 2016-01-31 07:53 EST (History)
6 users (show)

See Also:
Fixed In Version: pdns-3.4.7-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-30 23:32:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boden Garman 2016-01-27 19:04:59 EST
Description of problem:
Update to mbedtls causes a dependency issue with pdns


Version-Release number of selected component (if applicable):
pdns.x86_64                      3.4.7-1.el7                     @epel          
pdns-backend-mysql.x86_64        3.4.7-1.el7                     @epel          
pdns-backend-pipe.x86_64         3.4.7-1.el7                     @epel          
pdns-tools.x86_64                3.4.7-1.el7                     @epel  
mbedtls.x86_64                   1.3.14-1.el7                    @epel

How reproducible:


Steps to Reproduce:
1. Enable epel
2. Install pdns 3.4.7-1.el7 and then run "yum update" 

Actual results:
Error: Package: pdns-3.4.7-1.el7.x86_64 (@epel)
           Requires: libmbedtls.so.9()(64bit)
           Removing: mbedtls-1.3.14-1.el7.x86_64 (@epel)
               libmbedtls.so.9()(64bit)
           Updated By: mbedtls-2.2.1-1.el7.x86_64 (epel)
              ~libmbedtls.so.10()(64bit)
Error: Package: pdns-tools-3.4.7-1.el7.x86_64 (@epel)
           Requires: libmbedtls.so.9()(64bit)
           Removing: mbedtls-1.3.14-1.el7.x86_64 (@epel)
               libmbedtls.so.9()(64bit)
           Updated By: mbedtls-2.2.1-1.el7.x86_64 (epel)
              ~libmbedtls.so.10()(64bit)

Expected results:
Updated packages

Additional info:
Comment 1 Fedora Update System 2016-01-27 19:55:12 EST
pdns-3.4.7-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c3fc50614c
Comment 2 Morten Stevens 2016-01-27 19:57:59 EST
Thank you for the bug report.

Could you please try the latest update (pdns-3.4.7-2.el7) and give as stable karma +1 on https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c3fc50614c

Thank you.
Comment 3 Fedora Update System 2016-01-29 11:21:08 EST
pdns-3.4.7-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c3fc50614c
Comment 4 Fedora Update System 2016-01-30 23:32:49 EST
pdns-3.4.7-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Morten Stevens 2016-01-31 07:53:11 EST
*** Bug 1303343 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.