Bug 1302505 - Puppet agent is not automatically registering to Satellte(puppet master)
Puppet agent is not automatically registering to Satellte(puppet master)
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.6
Unspecified Unspecified
urgent Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 20:47 EST by jnikolak
Modified: 2016-01-27 22:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 22:03:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jnikolak 2016-01-27 20:47:36 EST
Steps to Reproduce:

1) Create Vm Machine in vmware with Red hat 6 or 7.

2) Then register and subscribe the vm to Satellite

3) Download the packages, puppet

4) populate the /etc/puppet.conf
Other Details and 
certificate_revocation = false

5) Run puppet agent -t -o 

6) Sign the certificate with (because we have no autosign)
puppet cert sign --all


7) Then run puppet-agent -t -o ( we have to run puppet agent again to get environment)
Getting error:
Exiting; no certificate found and waitforcert is disabled



We found workaround, but this requires extra steps, 
########################################

1) Create Vm Machine in vmware with Red hat 6 or 7.

2) Then register and subscribe the vm to Satellite

3) Download the packages, puppet

4) populate the /etc/puppet.conf
Other Details and 
certificate_revocation = false

5) Run puppet agent -t -o 

6) Sign the certificate with (because we have no autosign)
puppet cert sign --all

7) From Satellite Master, run :
puppet cert clean hostname,

8) from puppet agent(host) 
rm -rf /var/lib/puppet/ssl/*

9) Then run puppet-agent -t -o ( we have to run puppet agent again to get environment)

10) Go to Satellite and assign the puppet environment

11) it now works


How can we get this working without the extra steps?
Comment 1 jnikolak 2016-01-27 22:03:56 EST
this can be closed, issue was resolved by:

The issue was resolved by signing the certificate before puppet agent was run.
This was resolved by running adding a timer to puppet with -w option.

We also added certificate_revocation = false however not  confirmed if this fix helped the issue.
In addition to that, the order of enabling and puppet was changed.

Note You need to log in before you can comment on or make changes to this bug.