Bug 1302510 - dnf: unhandled exception for dnf history info command
dnf: unhandled exception for dnf history info command
Status: CLOSED DUPLICATE of bug 1303149
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 21:44 EST by Marek Doležel
Modified: 2016-02-01 14:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 08:04:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DNF backtrace (1.33 KB, text/plain)
2016-01-27 21:44 EST, Marek Doležel
no flags Details

  None (edit)
Description Marek Doležel 2016-01-27 21:44:01 EST
Created attachment 1118979 [details]
DNF backtrace

Description of problem: Unhandled exception occurs when running dnf history info command. 


Version-Release number of selected component (if applicable):1.1.6-1.fc24


How reproducible: Always


Steps to Reproduce:
1. run sudo dnf history info 
or
sudo dnf history 2 # crashes regardless of actual transaction id

Actual results: Exception is not handled and program "crashes".


Expected results:Show information about specified transaction.


Additional info:
Comment 1 Erick 2016-01-29 00:37:49 EST
I have the described issue since this morning. Also to mention that a repodata directory was mislabeled in SELinux. However relabeling with restorecon didn't fix the issue with dnf history info.
Comment 2 Erick 2016-01-29 02:07:37 EST
Also another AVC error re performing finds on repodata directories was also found. Fixing this error also didn fix the dnf history info command.
Comment 3 Vít Ondruch 2016-01-29 04:04:57 EST
I observed the same issue. Disappeared after first installation. Now it seems I can use "history" as I wish.
Comment 4 Vít Ondruch 2016-01-29 04:09:38 EST
Actually, I was wrong. I can see the history of last operation, but can't see the "last-1". I suspect this will be related to bug 1239274 (yes, I can see the cmdline in output now).
Comment 5 Erick 2016-01-29 05:06:19 EST
same situation here as at Vit's.
Comment 6 fulminemizzega 2016-01-29 07:42:56 EST
Vit, Erick,
I'm seeing a different behaviour: dnf history info of every transaction happened after dnf update to 1.1.6 (that fixed bug 1239274) works fine. If you look at the attachment I uploaded in that bug (I'm sorry I did the wrong thing, should I also attach the same file on this bug report?), I did update dnf in transaction 132, and dnf history info works with everything with id >= 133. If I instead try to see info of every id < 133, I get the error.
I did check that every transaction with id < 133 does not work doing this:
for i in {1..132}; do dnf history info $i 2>&1 | grep AttributeError ; done >> output
then wc -l  and got 132 lines.
If you still look at my dnf history attachment, I was running F22 until transaction 92, where you can see that I did the upgrade to F23. So even transactions done with dnf in F22 that didn't have bug 1239274 do not work with dnf history info.
Comment 7 Honza Silhan 2016-02-01 08:04:43 EST

*** This bug has been marked as a duplicate of bug 1303149 ***
Comment 8 srakitnican 2016-02-01 08:44:20 EST
By downgrading to dnf-plugins-core-0.1.15-1.fc23.noarch.rpm both history info and history command line works.

http://koji.fedoraproject.org/koji/buildinfo?buildID=706439
Comment 9 srakitnican 2016-02-01 08:51:58 EST
Never mind, it is working only for last transaction, still the same traceback.
Comment 10 Marek Doležel 2016-02-01 14:53:00 EST
(In reply to Jan Silhan from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 1303149 ***

I think it should be the other way. As this bug was reported earlier.

Note You need to log in before you can comment on or make changes to this bug.