Bug 1302528 - Remove brick command execution displays success even after, one of the bricks down.
Remove brick command execution displays success even after, one of the bricks...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Sakshi
:
Depends On: 1201205
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 23:53 EST by Sakshi
Modified: 2016-07-31 21:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1201205
Environment:
Last Closed: 2016-04-15 01:12:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-28 00:00:02 EST
REVIEW: http://review.gluster.org/13306 (glusterd: check if all bricks are started before performing remove-brick) posted (#1) for review on release-3.7 by Sakshi Bansal
Comment 2 Vijay Bellur 2016-01-28 05:53:44 EST
REVIEW: http://review.gluster.org/13306 (glusterd: check if all bricks are started before performing remove-brick) posted (#2) for review on release-3.7 by Sakshi Bansal
Comment 3 Vijay Bellur 2016-02-04 04:33:32 EST
REVIEW: http://review.gluster.org/13306 (glusterd: check if all bricks are started before performing remove-brick) posted (#3) for review on release-3.7 by Sakshi Bansal
Comment 4 Vijay Bellur 2016-02-22 05:25:59 EST
COMMIT: http://review.gluster.org/13306 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 4d3b3d3f8a26b65e6a235d937baff40eefd577fd
Author: Sakshi <sabansal@redhat.com>
Date:   Thu May 28 10:49:36 2015 +0530

    glusterd: check if all bricks are started before performing remove-brick
    
    Due to low severity the patch was not immediately backported.
    
    > Backport of http://review.gluster.org/#/c/10954/
    
    > Change-Id: Ie9e24e037b7a39b239a7badb983504963d664324
    > BUG: 1225716
    > Signed-off-by: Sakshi <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/10954
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: Ifc6088949f3891c28c4941b3377c72b68b68cb29
    BUG: 1302528
    Signed-off-by: Sakshi <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13306
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 5 Kaushal 2016-04-19 03:24:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.