Bug 1302595 - "domains" description in pam_sss(8) is misleading
"domains" description in pam_sss(8) is misleading
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: SSSD Maintainers
Steeve Goveas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 03:50 EST by Aneta Šteflová Petrová
Modified: 2018-05-29 04:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 16:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aneta Šteflová Petrová 2016-01-28 03:50:35 EST
Description of problem:

From the "domains" option description in pam_sss(8):

---------------
NOTE: Must be used in conjunction with the “pam_trusted_users” and “pam_public_domains” options.
---------------

The sentence implies that users who want to use "domains" must also define "pam_trusted_users" and "pam_public_domains". This isn't true – there is no need to specify the two options when using "domains".


Can you please consider rephrasing the description to prevent this kind of confusion?
Comment 1 Lukas Slebodnik 2016-01-28 03:57:38 EST
Pavel wrote this feature.
Comment 3 Jakub Hrozek 2016-01-28 12:22:11 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2946
Comment 6 Jakub Hrozek 2017-03-28 04:09:15 EDT
This bugzilla still needs work upstream. Because we are nearing the development freeze of RHEL-7.4 and the work is not finished yet, I'm reproposing the bug to RHEL-7.5.

Please push back if you disagree.
Comment 7 Jakub Hrozek 2017-08-07 16:06:29 EDT
Thank you very much for filing this bug.

Since the issue is already tracked upstream and the fix will make its way into one of the future RHEL releases in a rebase, I'm going to close this bugzilla with the resolution of UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.