Bug 1302598 - [RFE] Add to ovirt_engine_history views that simplifies users usage of dwh views
[RFE] Add to ovirt_engine_history views that simplifies users usage of dwh views
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-dwh
Classification: oVirt
Component: Database (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Shirly Radco
Lukas Svaty
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 03:54 EST by Shirly Radco
Modified: 2016-08-22 21:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
To simplify Data Warehouse database views for the user, this update adds a view for each time period (sample, hourly, and daily). The views join the configuration views with statistics views of the entities it relates to, for example network interface and disks. This means three new views have been added for virtual machines, and three for hosts.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:45:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
pnovotny: testing_plan_complete-
ylavi: planning_ack+
sradco: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57451 master MERGED history: added over_time views to simplify use 2016-05-18 01:08 EDT

  None (edit)
Description Shirly Radco 2016-01-28 03:54:39 EST
Description of problem:

We want to add views that will join views to be more user friendly.
That means having for each time period (sample/hourly/daily) views that join the configuration views with statistics views of the entity it relates to.
Comment 1 Sandro Bonazzola 2016-05-02 05:52:26 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Lukas Svaty 2016-06-15 05:21:24 EDT
sanity only
added tables:
v4_0_fully_joined_statistics_hosts_resources_usage_daily  
v4_0_fully_joined_statistics_hosts_resources_usage_hourly v4_0_fully_joined_statistics_hosts_resources_usage_samples 4_0_fully_joined_statistics_vms_resources_usage_daily     v4_0_fully_joined_statistics_vms_resources_usage_hourly  | v4_0_fully_joined_statistics_vms_resources_usage_samples   

verified in ovirt-engine-dwh-setup-4.0.0-2.el7ev.noarch
Comment 3 Sandro Bonazzola 2016-07-05 03:45:06 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.