This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130261 - NFS map_static option not working
NFS map_static option not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 11:49 EDT by Don Walters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 15:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Walters 2004-08-18 11:49:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
I put the following line in /etc/exports...

/home/user1 192.168.0.1(rw,map_static=/etc/exports.map)

When I restart NFS, I get the following error...

exportfs: /etc/exports:1: unknown 
keyword "map_static=/etc/exports.map"

Apparently the map_static keyword isn't recognized.  Removing it 
allows NFS to start normally.


Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-1

How reproducible:
Always

Steps to Reproduce:
1.Add the map_static keywork into /etc/exports
2.Restart NFS (service nfs restart)
    

Actual Results:  Error message

Expected Results:  NFS start normally and allow user mapping

Additional info:
Comment 1 Steve Dickson 2004-10-12 15:26:17 EDT
Was map_static ever supported?
Comment 2 Don Walters 2004-10-12 16:52:09 EDT
Beats me!  I've only been working with RH since rel 9.

My take is... if you don't want to fix it, or don't think it should 
be fixed, the function should probably be removed from the 
documentation.
Comment 3 Steve Dickson 2004-10-12 18:32:57 EDT
Hey Don,

I've looked in the exportfs(8), exports(5) and nfsd(8) man
pages and could not find where map_static was talked about.
What documentation are you refereeing to?

Note You need to log in before you can comment on or make changes to this bug.