Bug 130263 - default CPAN mirror does not exist
default CPAN mirror does not exist
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Vipool Rathod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 11:54 EDT by Vipool Rathod
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 12:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vipool Rathod 2004-08-18 11:54:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
/usr/lib/perl5/5.8.0/CPAN.pm contains the default site for perl
modules - "ftp://ftp.perl.org".  The site seems to not exist.  I
believe the default sites could be "http:://www.perl.com/CPAN" or
"http://www.cpan.org".


Version-Release number of selected component (if applicable):
perl-CPAN-1.61-88.4

How reproducible:
Always

Steps to Reproduce:

1. Move /usr/lib/perl5/5.8.0/CPAN/Config.pm aside if you already
configured CPAN.
2. at shell prompt: "perl -MCPAN -eshell"
3. accept defaults until you get to the point where a list of mirrors
are downloaded.  This will not work.


Actual Results:  Asked to enter in a mirror by hand.

Expected Results:  Mirrors should be downloaded and a list produced.

Additional info:
Comment 1 Chip Turner 2004-08-30 11:51:05 EDT
seems to work for me; are you sure you don't have a firewall or proxy
or something blocking it from working for you?
Comment 2 Vipool Rathod 2004-08-30 12:14:07 EDT
Sorry, I think at the time I submitted the bug the site was going
through some DNS changes.  It looks okay now.  Although, the site
looks like a mirror in VA and the FTP server there seems picky (I'm
blocking identd).  Perhaps pointing to one of the default CPAN sites
may be a good idea?  I'm going to set this as resolved since this is
now more of a suggestion than a bug.  Thanks for looking into it.

Note You need to log in before you can comment on or make changes to this bug.