Bug 1302657 - [RFE] Switch from vnc/cirrus to vnc/vga
[RFE] Switch from vnc/cirrus to vnc/vga
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
4.0.0
x86_64 Unspecified
medium Severity medium (vote)
: ovirt-4.0.4
: 4.0.4
Assigned To: Marek Libra
meital avital
: FutureFeature, Improvement
Depends On:
Blocks: 1425410
  Show dependency treegraph
 
Reported: 2016-01-28 05:32 EST by Milan Zamazal
Modified: 2017-02-21 06:49 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, the default VNC graphics in Red Hat Virtualization 4.0 is VGA. Imported virtual machines with VNC/Cirrus, and originating in previous compatibility versions, are automatically upgraded to VNC/VGA. However, QXL is still the preferred default graphics, if the guest operating system supports it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 08:39:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.z+
mavital: testing_plan_complete+
mgoldboi: planning_ack+
mgoldboi: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55636 master MERGED core: QXL as default for VNC 2016-04-11 09:50 EDT
oVirt gerrit 56560 master MERGED core: VGA as default for VNC 2016-04-25 09:25 EDT
oVirt gerrit 56623 master MERGED core: VNC/VGA allowed for 3.6 VMs on PPC 2016-04-26 09:30 EDT
oVirt gerrit 62354 master MERGED core: Switch from cirrus to vga at cluster upgrade 2016-08-22 07:41 EDT
oVirt gerrit 62924 ovirt-engine-4.0 MERGED core: Switch from cirrus to vga at cluster upgrade 2016-08-30 08:18 EDT
oVirt gerrit 63018 ovirt-engine-4.0.4 MERGED core: Switch from cirrus to vga at cluster upgrade 2016-08-30 09:06 EDT

  None (edit)
Description Milan Zamazal 2016-01-28 05:32:51 EST
According to QEMU/KVM graphics developers, when all things are considered (driver support in guest OSes, performance, features, etc.), VGA is clearly preferable fallback choice over Cirrus when using VNC on x86*.  So it should be considered switching the default choice in oVirt.

Please note the switch shouldn't be done before SPICE QE tests it and confirms the change is OK.
Comment 1 Michal Skrivanek 2016-02-19 07:48:21 EST
introduce in new cluster level
convert on cluster upgrade with a warning
need to keep supporting 3.6-level clusters(and VMs) with cirrus, also on import
Comment 2 Yaniv Kaul 2016-03-03 15:20:07 EST
David & David - thoughts?
Comment 8 Michal Skrivanek 2016-04-19 02:31:47 EDT
the current patch changes VNC to QXL, but there are issues with QXL on older guests. We need to either change that to VGA or revert back to CIRRUS
Comment 9 Michal Skrivanek 2016-04-19 04:30:33 EDT
or keep CIRRUS as an option for people who have issues. I would still prefer to change the default away from CIRRUS to nudge users into more modern card
Comment 10 meital avital 2016-08-09 15:51:05 EDT
I tried to verify this RFE on version: 4.0.2.3-0.1.el7ev

The import flow work, but the CL upgrade is not working - means after CL upgrade the VNC/Cirrus do not switch to VNC/VGA.
Comment 11 Red Hat Bugzilla Rules Engine 2016-08-09 15:51:14 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 12 Michal Skrivanek 2016-08-10 08:10:10 EDT
hm, there was some discussion about changing existing VMs. Apparently it is not done right now, but we may still want to do that.
Changing to 4.0 CL is a good time to do that
Comment 13 Sandro Bonazzola 2016-08-31 08:41:48 EDT
Not included in 4.0.4 rc1, please don't move to QE until next build
Comment 14 Sandro Bonazzola 2016-09-01 01:54:50 EDT
I've been ignored. Moving back to modified.
Comment 15 meital avital 2016-09-18 07:21:16 EDT
Verified on version : 4.0.4.2-0.1.el7ev

Now the CL upgrade works properly.

Note You need to log in before you can comment on or make changes to this bug.