Bug 130267 - Fedora-gdm does not recognize the Files in /etc/X11/gdm/Sessions/
Fedora-gdm does not recognize the Files in /etc/X11/gdm/Sessions/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 12:27 EDT by Hanno
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 18:58:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hanno 2004-08-18 12:27:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Bad:
I have installed fvwm2
I have created /etc/X11/gdm/Sessions/FVWM2

-----Begin FVWM2-----
#!/bin/bash
exec /usr/local/bin/fvwm2
-----End FVWM2-----

The new FVWM-Windowmanager can not be choosen at the gdm-Loginscreen.
Only the Gnome-Windowmanager and the Failsafe-Terminal is displayed
during the Choosing-Dialog.
When I start the Gnome-Windowmanager and log-out later, the Monitor
becomes black and the Computer dos not react to Keystrokes.
When I erase /etc/X11/gdm/Sessions/FVWM2, gdm works well.

Version-Release number of selected component (if applicable):
gdm-2.6.0.0-3

How reproducible:
Always

Steps to Reproduce:
1. install fvwm2
2. creat /etc/X11/gdm/Sessions/FVWM2

  -----Begin FVWM2-----
  #!/bin/bash
  exec /usr/local/bin/fvwm2
  -----End FVWM2-----
3.  Try to choose the FVWM. It is not diplayed in the Coosing-Dialog.

    

Actual Results:  FVWM2 is not diplayed in the Coosing Dialog at the
Login-Screen.


Expected Results:  The Point FVWM2 should have been displayed, so that
I can choose this Point an then login with the fvwm-Windowmanager.

Additional info:
Comment 1 Hanno 2004-08-19 08:25:03 EDT
The Computer-Crash after logging out has nothing to do with the gdm.
If I change /etc/sysconfig/desktop

from
-----Begin original File-----
DESKTOP="GNOME"
-----End original File-----

to
-----Begin new File-----
DISPLAYMANAGER="KDE"
-----End new File-----
(Yes, the real Variablename is DISPLAYMANAGER !. DESKTOP IS WRONG
SINCE REDHAT_8!)

the kdm (KDE Display Manager) starts and the Computer crashes after
logging out as well.

So the Problem that is left as far as gdm ist concerned, is, that gdm
does not recognize the (executable) Files in the
/etc/X11/gdm/Sessions/ Directory.


Greetings
Hanno (u13927@gmx.de)
Comment 2 Hanno 2004-08-19 09:00:09 EDT
Sorry,
DESKTOP is not so wrong as I said.
It is used by th Script in
/etc/X11/xinit/Xclients

Greetings 
Hanno (u13927@gmx.de)
Comment 3 Hanno 2004-08-19 10:34:52 EDT
I have just found out, that when I create a File
/etc/X11/dm/Sessions/fvwm2.desktop
similar to
/etc/X11/dm/Sessions/gnome.desktop (that allready exists from the
rpm-Gnome-Package), I get the Point FVWM2 in the gdm-Session-Menue.

I have installed the original Fedora2-KDE-Package and there is no
/etc/X11/dm/Sessions/kde.desktop. There is only a
/etc/X11/gdm/Sessions/KDE. 
Strangely the Point KDE appears in the gdm-Session-Menue. 
So there must be 2 different Ways to let the Menuepoints appear in the
gdm-Session-Menue.

I think, that there schould only be 1 right Way (how it is described
in the gdm-Dokumentation), to "edit" the gdm-Session-Menue.
I think, it is not good, that Fedora "invents" new Things, that differ
from the original gdm-Documentation. It is difficult enough to read
the original gdm-Documentation. I do not have the Time to learn
special Fedorathings.
Greetings
Hanno (u13927@gmx.de)

P.S. It is the first Time, that I have written Something into the
Errata. It would be helpful, if I could edit my previous Writings,
because there are a lot of Errors from my Side in there. I could so
save the Readers a lot of Time reading senseless Words and the
following Corrections.
Comment 4 Ray Strode [halfline] 2004-11-05 18:58:59 EST
Hi Hanno,

The second method you found is a new standardized way of adding items
to the session menu (that works with display managers other than GDM).
It is not in anyway Fedora specific. You were probably having problems
using the original method because you may have forgotton to put
execute permissions on your file.

Hope that helps.

Note You need to log in before you can comment on or make changes to this bug.