Bug 1302695 - Files are not scanned for VMs during SSA
Files are not scanned for VMs during SSA
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Hui Song
Dave Johnson
:
Depends On:
Blocks: 1302836
  Show dependency treegraph
 
Reported: 2016-01-28 07:07 EST by Vadim Rutkovsky
Modified: 2016-02-13 14:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302836 (view as bug list)
Environment:
Last Closed: 2016-02-08 06:13:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EVM debug log (827.75 KB, text/plain)
2016-01-28 07:07 EST, Vadim Rutkovsky
no flags Details
EVM debug log 2 (702.84 KB, application/x-gzip)
2016-02-01 07:25 EST, Vadim Rutkovsky
no flags Details

  None (edit)
Description Vadim Rutkovsky 2016-01-28 07:07:18 EST
Created attachment 1119112 [details]
EVM debug log

Description of problem:
Files are not scanned during SSA even with a custom scanning profile

Version-Release number of selected component (if applicable):
5.5.2.2.20160121120249_395c086 

How reproducible:
Always

Steps to Reproduce:
1. Create a new Analysis Profile for VM
2. On Files tab add any valid pattern (e.g. '/etc/hosts', '/etc/*.conf')
3. Run SSA on any valid linux VM
4. Open VM details

Actual results:
Files are not scanned - Configuration/Files shows 0

Expected results:
Files are scanned according the created profile

Additional info:
Tested on rhevm34 and vsphere55 providers. Hosts work with scanning profiles correctly
Comment 1 Vadim Rutkovsky 2016-01-28 10:22:36 EST
It appears that hosts are affected too - adding a new host profile doesn't change a list of fetched files - only the default ones seems to be taken in consideration.
Comment 9 Vadim Rutkovsky 2016-02-01 07:25 EST
Created attachment 1120090 [details]
EVM debug log 2

Reproduced on new appliance. Created a new action "SSA action", new policy "SSA policy" to assign a created action on VM analysis request and policy profile "SSA policy profile" to assign a default 'sample' profile to a VM.

The same operation works on 5.4.5.0
Comment 10 Shveta 2016-02-02 19:15:04 EST
Assigning to add test case
Comment 13 Vadim Rutkovsky 2016-02-08 06:13:07 EST
Right, it works when I set the action to 'VM Analysis Start' event, not 'VM Analysis Request' (as I did before). Not sure if this is a bug, documentation is not clear about this one - I will consult with other qa's and file a new bug for this.


Thanks for clearing this out, sorry for the noise - closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.