Bug 130271 - Tecra 8000 no sound
Tecra 8000 no sound
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-08-18 12:42 EDT by Lai Tang
Modified: 2015-01-04 17:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lai Tang 2004-08-18 12:42:03 EDT
Description of problem:
I have trying to get the Yamaha OPL3-SAx soundcard to detect on my 
Tecra 8000 with Fedora Core 2.
Fedora is crap on old hardware such as Tecra 8000. This is driving me 
Spending hours trying to get a stupid sound card to work.

mY kernel is 2.6.5-1.358 and i downloaded the next one up(can't 
remember exact no).

My sound card is on irq 5 in the bios. 

Fedora can't detect it through lspci:

00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host 
bridge (AGP disabled) (rev 03)
00:04.0 VGA compatible controller: Neomagic Corporation NM2200 
[MagicGraph 256AV] (rev 12)
00:05.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:05.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:05.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:05.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:09.0 Communication controller: Toshiba America Info Systems FIR 
Port (rev 23)00:0b.0 CardBus bridge: Toshiba America Info Systems 
ToPIC97 (rev 05)
00:0b.1 CardBus bridge: Toshiba America Info Systems ToPIC97 (rev 05)

I have tried ALSA but i read some forum to say i don't need it and it 
does not work when i try to insert into the kernel:

modprobe snd-opl3sa2;modprobe snd-pcm-oss;modprobe snd-mixer-
oss;modprobe snd-seq-oss

i tried to insert the soundcard int the modprobe.conf:

cat /etc/modprobe.conf
alias eth0 3c589_cs
alias usb-controller uhci-hcd

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-opl3sa2
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

I have a pcmcia network and usb mouse that was irq confilcting but i 
fixed it by adding 'pci=bios' and 'acpi=noirq'; to the grub.
I have tried changing the IRQ's of the soundcard and it did not work.

Has anyone worked out how to get yahama sound card to detect?

Comment 1 Bill Nottingham 2005-01-21 17:15:16 EST
This is *probably* a driver issue. Non-PNP isa cards aren't
automatically detected.
Comment 2 Dave Jones 2005-04-16 01:20:39 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.