Bug 1302710 - REST remote API under FUSE 6.1.1 is unable to start process
REST remote API under FUSE 6.1.1 is unable to start process
Status: CLOSED WONTFIX
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Fuse Integration (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Marco Rietveld
Jiri Petrlik
Petr Penicka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 07:28 EST by Jiri Petrlik
Modified: 2016-09-20 01:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 03:51:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (4.76 KB, text/plain)
2016-01-28 07:28 EST, Jiri Petrlik
no flags Details
reproducer (13.53 KB, application/zip)
2016-01-28 07:30 EST, Jiri Petrlik
no flags Details

  None (edit)
Description Jiri Petrlik 2016-01-28 07:28:38 EST
Created attachment 1119134 [details]
Stack trace

Description of problem:

REST remote API under FUSE 6.1.1 is unable to start process in business central. The problem is in JAXB classes. Stack trace and reproducer are provided in attachments. This problem is not present in Fuse 6.2.0 and 6.2.1.

Version-Release number of selected component (if applicable):
BPMS 6.2.1.CR1
Fuse 6.1.1

How reproducible:
Reproducer is provided.

Steps to Reproduce:
1. Build reproducer using Maven $ mvn clean install
2. Deploy kjar with process definitions to business central ("org.jboss.qa.brms.reproducer:rest-api-fuse-6.1.1-kjar:1.0-SNAPSHOT")
3. Download Fuse 6.1.1 zip distribution.
4. Edit "Configuration" constants in "RemoteRestApiTest.java" in module "rest-api-fuse-6.1.1-test" according to your local settings.
5. Start test from folder "rest-api-fuse-6.1.1-test" using Maven $ mvn clean test

Actual results:
The attempt to run test provided in reproducer will fail on exception:"Unsupported JAXB Class encountered during initialization: 2 counts of IllegalAnnotationExceptions"

Expected results:
Test in reproducer should pass.

Additional info:
Comment 2 Jiri Petrlik 2016-01-28 07:30 EST
Created attachment 1119135 [details]
reproducer
Comment 4 Jiri Petrlik 2016-01-29 03:51:02 EST
If we do not need to support Fuse 6.1.1, than I consider this bug as closed.

Note You need to log in before you can comment on or make changes to this bug.