Bug 1302753 - bad directory search
bad directory search
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fail2ban (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 09:34 EST by dev002
Modified: 2016-01-29 15:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 15:53:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dev002 2016-01-28 09:34:17 EST
Description of problem:
customisation.local:
apache_error_log = /var/log/httpd/*/*/*error*

Version-Release number of selected component (if applicable):


How reproducible:
apache_error_log = /var/log/httpd/*/*/*error* on config file. The path should have "/*/", in other case fail2ban works.

Steps to Reproduce:
1. configure multiple directories search expression
2. run fail2ban
3. fail to start: ERROR  No file(s) found for glob

Actual results:
exits with ERROR  No file(s) found for glob

Expected results:
work with "/*/*/.../*file*" expressions

Additional info:
fail2ban-0.9.3-1.fc23.noarch
Comment 1 Orion Poplawski 2016-01-29 15:53:05 EST
I'm sorry, I really don't understand what problem you are having.  I think it may be because your customization file needs to be named jail.local with:

[DEFAULT]
apache_error_log = /var/log/httpd/*/*/*error*

[apache-auth]
enabled = true

then:

# mkdir -p /var/log/httpd/{a,b,c,d}/{a,b,c,d}
# touch /var/log/httpd/{a,b,c,d}/{a,b,c,d}/error{1,2,3,4}
# systemctl start fail2ban
# fail2ban-client get apache-auth logpath
Current monitored log file(s):
|- /var/log/httpd/a/a/error1
|- /var/log/httpd/a/a/error2
|- /var/log/httpd/a/a/error3
|- /var/log/httpd/a/a/error4
|- /var/log/httpd/a/b/error1
....


Looks like I also had an issue with selinux-policy-3.13.1-152.fc23, but updating to 3.13.1-158.2.fc23 seemed to clear that up.  So maybe that was an issue for you too.

Note You need to log in before you can comment on or make changes to this bug.