Bug 1302765 - Load only changes in lists
Load only changes in lists
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity high
: ---
: 3
Assigned To: Soumya Deb
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 10:06 EST by Martin Kudlej
Modified: 2017-03-23 00:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:12:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-01-28 10:06:47 EST
Description of problem:
Every few seconds lists are completely reloaded. This means that in case of long list of hosts(or any other list) data on page can disappear until list of hosts(or any other list data) is processed -> performance problem. Also menu for deleting host(or any other menu for item in list) can be closed because user click on open menu right before list is reloaded. So I suggest to add/remove only added/removed hosts(or in any other list). If you install skyring on remote machine you can see that lists are blinking(reloading) because of this issue.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-1.el7.x86_64
rhscon-ceph-0.0.6-1.el7.x86_64
rhscon-ui-0.0.7-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. load any list with many items, for example hosts and watch periodical reloading

Actual results:
Lists are periodically completely reloading.

Expected results:
UI will load only changes in lists which should be periodically changed.
Comment 3 :Deb 2016-05-11 08:49:02 EDT
Most list pages have 5-10sec aggressive polling, reloading and reflowing the entire content DOM, this is essentially to keep tab on the utilization details.

Also, the flickering is noticeable for high number of graphs and charts in the view trying to get updated all at the same time.

As the utilization details are updated every 10min in the backend, it only makes sense to reduce the aggressiveness of the polling to 1min. With all the charts overloaded in the page, the page might still flicker, but not as often. And with the current UX suggestion, there's not too many feasible solution to reduce charts in the page. So increasing poll-timer seems most go to solution for the moment.
Comment 4 Nishanth Thomas 2016-06-20 08:31:30 EDT
Moving to 3.0

Note You need to log in before you can comment on or make changes to this bug.