Bug 130277 - Sony laptop pcmcia cdrom conflict hangs anaconda
Summary: Sony laptop pcmcia cdrom conflict hangs anaconda
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-18 18:04 UTC by Paul Wouters
Modified: 2015-01-04 22:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 06:50:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Wouters 2004-08-18 18:04:20 UTC
Description of problem:

On my Sony SR11K laptop with pcmcia cdrom drive, installs are always
painful. Only redhat 7.x worked properly. Once you boot from cdrom,
you must specify ide1=0x180,0x386 for the cdrom to keep working. This
creates an hdc device. Stuff boots on until it loads the yenta_socket,
when it finds another ide device. this becomes hde,
From this point on, the cdrom logs ide timeout errors and fails.
note that I cannot disable the idex= line because then it won't find
the cdrom and won't load the initrd, modules and pcmcia tools. But I
also cannot disable pcmcia detection from Anaconda (AFAIK). I can also
not disable pcmcia in the very limited award bios that Sony ships.

I tried all combinations i could think of as specified in the linux
kernel documention's ide.txt (eg idex=noprobe, hdc=noprobe, and even
things like hdc=scsi or hdc=0x0,0x0)


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Find Sony SR11K with cdrom
2. Insert FC 3 test 1
3. wait
  
Actual results:
ide timeouts

Expected results:
perfectly smooth installation :)

Additional info:

Comment 1 Jeremy Katz 2004-08-18 18:07:15 UTC
You also need to add pci=off if I remember correctly.

Comment 2 Paul Wouters 2004-08-18 18:13:33 UTC
Jeremy: I love you :)

That fixed the problem indeed.


Note You need to log in before you can comment on or make changes to this bug.