Bug 1302774 - IPv6 RabbitMQ connection shows periodic Exception in the reader loop: AMQ::Protocol::EmptyResponseError: Empty response received from the server
IPv6 RabbitMQ connection shows periodic Exception in the reader loop: AMQ::Pr...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.3
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
: ZStream
Depends On: 1302362
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 10:24 EST by Chris Pelland
Modified: 2017-08-29 23:49 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302362
Environment:
Last Closed: 2016-04-13 14:42:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-03-11 09:59:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5bac7f3bb74c7fc6108fa2a5913ab67eae2b1ee4

commit 5bac7f3bb74c7fc6108fa2a5913ab67eae2b1ee4
Merge: 8171111 bffc540
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Mar 11 09:40:14 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Fri Mar 11 09:40:14 2016 -0500

    Merge branch 'bz1302774' into '5.5.z'
    
    Make AMQP heartbeat configurable
    
    By default bunny takes the setting from the AMQP settings. If
    this setting is too low (like 1s) it might fail to give response
    in time, causing reconnect.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1302362
    
    Clean cherry-pick of:
    https://github.com/ManageIQ/manageiq/pull/7027/
    
    Fixes 5.5.z BZ
    https://bugzilla.redhat.com/show_bug.cgi?id=1302774
    
    See merge request !837

 app/models/manageiq/providers/openstack/event_catcher_mixin.rb | 7 ++++---
 config/vmdb.tmpl.yml                                           | 2 ++
 gems/pending/openstack/amqp/openstack_rabbit_event_monitor.rb  | 3 ++-
 gems/pending/openstack/openstack_event_monitor.rb              | 1 +
 4 files changed, 9 insertions(+), 4 deletions(-)
Comment 5 errata-xmlrpc 2016-04-13 14:42:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.