Bug 1302775 - RHEL6-17112 - RHSM : Firstboot - Verify if user can navigate thro firstboot pages
RHEL6-17112 - RHSM : Firstboot - Verify if user can navigate thro firstboot p...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Chris Snyder
John Sefler
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 10:30 EST by Jan Stavel
Modified: 2016-05-10 16:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sequence of screens (483.89 KB, application/zip)
2016-01-28 10:30 EST, Jan Stavel
no flags Details

  None (edit)
Description Jan Stavel 2016-01-28 10:30:49 EST
Created attachment 1119181 [details]
sequence of screens

link to Polarion TestCase

https://polarion.engineering.redhat.com/polarion/#/project/RHEL6/workitem?id=RHEL6-17112&revision=479643
Description of problem:
User cannot see server details after he click "Back" button.

How reproducible:
Launch Firstboot and Accept the License Agreement 
------> Select "Register to Subscription-Management Service " Option 
------> Enter the server Details and click on Next 
------> Now Click on "Back" button on the page where you are supposed to enter credentials

Actual results:
There is no server details window.

Expected results:
User should be able to change server details after he decides to go back.


Additional info:

I have attached screenshots how they appeared.

Thanks,
Jan Stavel
Comment 3 John Sefler 2016-01-28 12:58:39 EST
Saving some time...
This bug is indeed a Regression from the RHEL6.7 version of subscription-manager-firstboot-1.14.10-1.el6.x86_64

I suspect the development of RHEL7 subscription-manager-initial-setup-addon-1.15.9-15.el7.x86_64 has introduced this regression on el6.
Comment 9 John Sefler 2016-02-03 15:21:08 EST
Adding more observations to this bugzilla....

Once the user has successfully gone "Forward" through all of the subscription-manager firstboot panels and successfully lands on the "Done" panel, clicking the "Back" button will navigate to the "Choose Service" panel which is effectively the module prior to subscription-manager-firstboot (which is arguably correct), then a click of the "Forward" button tries to attach subscriptions again (which is not right).

Once the user has successfully gone "Forward" through all of the subscription-manager firstboot panels and successfully lands on the "Done" panel and then click the "Forward" button to the next module (Create User)), clicking the "Back" button will navigate to the "Attaching Subscription" panel which will oscillate and then throw an error dialog stating "No available subscriptions at the current service level...".  Arguably, this is not the best panel to go back to.  It might be better to go all the way back to the first prompt of the firstboot module to enter an entitlement server hostname.
Comment 12 John Sefler 2016-03-08 15:28:16 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.16.8-4.el6.x86_64


Testing Comment 0...
VERIFIED: When the user gets to the Subscription Management registration credentials panel, clicking Back will navigate all the way back to the "Choose Service" panel where a click of Forward will re-initiate subscription-manager-firstboot and the user can enter the server information details again.  This is the newly expected Back/Forward workflow behavior (to re-start the subscription-manager-firstboot panels from the beginning).


Testing Comment 9...
VERIFIED: When the user reaches the "Done!" panel and clicks Back, then Forward into Subscription Management, the user sees the "Done!" panel again.  This is the new expected behavior.  When the user is done, the user is done!  To change their registration, he will have to use the subscription-manager CLI/GUI tools post firstboot.
Comment 14 errata-xmlrpc 2016-05-10 16:39:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.