Bug 1302784 - ssh Key pair not working on CFME provision
ssh Key pair not working on CFME provision
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Joe Vlcek
luke couzens
openstack:vm:provision
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 10:45 EST by luke couzens
Modified: 2016-06-29 11:34 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description luke couzens 2016-01-28 10:45:26 EST
Description of problem: When provisioning a cloudforms appliance using RHOS the ssh key pair function does not seem to work correctly, you can add the key pair but it still requires a user and password when connecting to the appliance, it seems to be ignoring the pub/private keys. 


Version-Release number of selected component (if applicable):5.5.2.2


How reproducible:100%


Steps to Reproduce:
1. connect to RHOS
2. Launch new CFME instance
3. fill out wizard and add key pair
4. ssh into appliance

Actual results: key pair does not work


Expected results: login using key pair


Additional info:
Comment 2 Joe Vlcek 2016-01-28 17:51:21 EST
I have done a little research and think you need to specify the user name as: "cloud-user"

e.g.:
ssh -i <your key file>.key cloud-user@<ipaddr>


Please let me know if that works.
Comment 3 luke couzens 2016-01-29 06:53:48 EST
I created a new instance with my key pair and tested, but still no joy connecting with cloud-user, still requires a password from me.
Comment 4 Shveta 2016-02-02 19:15:19 EST
Assigning to add test case
Comment 5 Joe Vlcek 2016-02-23 11:52:01 EST
I have confirmed the fix for the cloud-init BZ 1300410 [1] also resolves this issue. Moving to post.


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1300410
Comment 6 Joe Vlcek 2016-02-23 12:55:32 EST
The username I was able to use successfully with my ssh keypair is "root"

e.g.:
ssh -i <your key file>.key root@<ipaddr>
Comment 7 luke couzens 2016-04-27 16:18:36 EDT
Verified in 5.6.0.4-beta2.3
Comment 9 errata-xmlrpc 2016-06-29 11:34:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.