Bug 1302801 - Need method to view pools belonging to a given subscription
Need method to view pools belonging to a given subscription
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: William Poteat
Jitendra Yejare
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 11:31 EST by Alex Wood
Modified: 2016-07-27 05:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Wood 2016-01-28 11:31:56 EST
We have had requests from users interested in scripting using the Candlepin API.  Currently, the API is missing a way to view the specific pools listed for a given subscription.  Users are reduced to fetching all pools and then sorting through the results.  Please add a method that allows users to get a list of pools associated with a specific subscription.
Comment 1 William Poteat 2016-02-09 07:15:39 EST
Commit 75fa6a0d6b58240b833c579fab7778bf5fa20a0a
Comment 5 Bryan Kearney 2016-02-18 16:19:57 EST
do I need to open up something for katello to consume this?
Comment 8 Jitendra Yejare 2016-04-25 06:28:41 EDT
What I should test here from Satellite perspective as its candlepin change ?
Comment 10 Jitendra Yejare 2016-04-26 09:57:59 EDT
What I should test here from Satellite perspective as its candlepin change ?
Comment 12 Jitendra Yejare 2016-07-19 09:17:56 EDT
Verified !

This bug has nothing to test from QE perspective so moving this to QE Verified !

Please feel free to reopen this bug if required.
Comment 13 Jitendra Yejare 2016-07-19 09:18:20 EDT
Verifying this in Sat 6.2 snap 20.2 GA.
Comment 15 errata-xmlrpc 2016-07-27 05:22:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.