Bug 1302803 - update the choice of the checksum calculation algorithms for repo creation
update the choice of the checksum calculation algorithms for repo creation
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.0.0
Assigned To: RHUI Bug List
Irina Gulina
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 11:36 EST by Irina Gulina
Modified: 2017-03-01 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-01 17:11:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Irina Gulina 2016-01-28 11:36:03 EST
Description of problem:
When one creates a repo, there is no word about what algorithm used for calculating the checksum values for repository metadata for RHEL7 machines.

Version-Release number of selected component (if applicable):
>> rpm -qa "*rhui*"
rh-amazon-rhui-client-rhs30-2.2.124-1.el7.noarch
rhui-installer-base-0.0.24-1.el7ui.noarch
rh-rhui-tools-libs-pre.3.0.16-1.el7ui.noarch
rhui-installer-0.0.24-1.el7ui.noarch
rh-rhui-tools-pre.3.0.16-1.el7ui.noarch
rhui-default-ca-1.0-1.noarch
rh-amazon-rhui-client-2.2.118-1.el7.noarch

RHUI iso 20151013


How reproducible:
always


Steps to Reproduce:
From home screen: 
1 'r' -  manage repositories
2. 'c' - create a new custom repository (RPM content only)

>> Unique ID for the custom repository (alphanumerics, _, and - only):
test_repo
>> Display name for the custom repository [test_repo]:
[ENTER]
Path at which the repository will be served [test_repo]:
[ENTER]

Algorithm to use when calculating the checksum values for repository metadata:
* Select "sha256" for RHEL6:
* Select "sha1" for either RHEL5 or RHEL6:

  1  - sha256
  2  - sha1
Enter value (1-2) or 'b' to abort: 



Actual results:
* Select "sha256" for RHEL6:
* Select "sha1" for either RHEL5 or RHEL6:


Expected results:
maybe change it into 
"If you create repo for RHEL5 use sha1, otherwise the default option is sha256"
  1  - sha256 (default)
  2  - sha1
Comment 4 Irina Gulina 2016-10-26 05:43:14 EDT
RHEL6 and 7 ISO's 20161025:

Algorithm to use when calculating the checksum values for repository metadata:

  1  - sha256 (default)
  2  - sha1 (RHEL 5)
Enter value (1-2) or 'b' to abort:

>> pulp-admin -u admin -p admin repo list --details
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                  unprotected_repo1
Display Name:        unprotected_repo1
Description:         unprotected_repo1
Content Unit Counts: 
Notes:               
  Checksumtype: sha256

.....

Id:                  unprotected_repo2_sha1
Display Name:        unprotected_repo2_sha1
Description:         unprotected_repo2_sha1
Content Unit Counts: 
Notes:               
  Checksumtype: sha1
Comment 5 errata-xmlrpc 2017-03-01 17:11:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367

Note You need to log in before you can comment on or make changes to this bug.