Bug 130281 - Kernel fails to load LVM
Kernel fails to load LVM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-18 15:14 EDT by George Toft
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log showing partitioning of drive (1.33 KB, text/plain)
2004-08-19 13:11 EDT, George Toft
no flags Details

  None (edit)
Description George Toft 2004-08-18 15:14:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Fedora Core 3 test 1
During installation, I set up the disk with LVM:
/dev/hda1 = /boot
/dev/hda2=/ with 5GB
/dev/hda3=swap 1GB
/dev/hda4=LVM - remainder of disk

Within LVM, groups were set up for /var, /home, /usr, and /usr/local

Installer made filesystems and installed software.  Upon reboot, 
kernel could not find any of the LVM filesystems.  seatching /etc 
showed no LVM config files.  dmesg had no trace of any LVM config or 
initialization.  fdisk -l showed partitions correctly built.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description - note: System was rebuilt without LVM, so 
additional troubleshooting on affected system in not possible.

Actual Results:  System would not mount filesystems

Expected Results:  System should have booted.

Additional info:
Comment 1 Jeremy Katz 2004-08-18 15:33:29 EDT
Is this reproducible?  We're setting up LVM by default now and I
haven't seen this occur.
Comment 2 George Toft 2004-08-18 18:56:25 EDT
Will build new machine to verify and post results.  --George Toft
Comment 3 George Toft 2004-08-19 13:11:26 EDT
Created attachment 102885 [details]
anaconda log showing partitioning of drive

rootpw and network entries have been sanitized.
Comment 4 George Toft 2004-08-19 13:18:33 EDT
Reproduced problem on different hardware.  Built "Custom" system (not
workstation or server), then selected minimum installation. 
Partitioned as shown in anaconda log.  SInce previous Linux system was
installed, I deleted all partitions except /dev/hda1 (already labeled
as /boot).  Will rebuild box again and will blow away all partitions.
 --George

Comment 5 George Toft 2004-08-19 13:57:31 EDT
Deleted all partitions and performed steps above.  Same result -
machine cannot read LVM data and leaves system in maintenance mode. 
--George
Comment 6 Jeremy Katz 2004-08-24 14:04:50 EDT
Can you go into rescue mode and put the following into /etc/lvm/lvm.conf

logging {
  verbose=3
}

and run 'lvm pvscan' and see if it says its skipping any of the
devices in your VG for any reason?
Comment 7 George Toft 2004-08-26 10:00:44 EDT
Unable to boot into rescue mode.  Error on screen reads:
Running anaconda, the Fedora Core rescue mode - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 592, in ?
    rescue.runRexcue(rootPath, not rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 167, in runRescue
    os.symlink('/mnt/runtime/etc/' + file, '/etc/' + file)
OSError: [Errno 17] File exists
Install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
       /mnt/runtime done
       disabling /dev/loop0
       /proc/buss/usb done
       /proc done
       /dev/pts done
       /sys done
       /tmp/ramfs done
       /selinux done
you may safely reboot your system

rebooted into rescue mode a second time with same results.
Comment 8 Jeremy Katz 2004-09-22 15:54:03 EDT
Should work now.

Note You need to log in before you can comment on or make changes to this bug.