Bug 1302814 - regression: Unattached child process should exist when the container is killed in docker container with pid=host
regression: Unattached child process should exist when the container is kille...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mrunal Patel
atomic-bugs@redhat.com
: Extras
Depends On: 1302807
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 11:54 EST by Daniel Walsh
Modified: 2016-02-22 14:37 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302807
Environment:
Last Closed: 2016-02-22 14:37:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2016-01-28 11:54:29 EST
+++ This bug was initially created as a clone of Bug #1302807 +++

Description of problem:

In the docker container with pid=host, the unattached child process shouldn't be killed when killing the container. 

Version-Release number of selected component (if applicable):

docker 1.9.1
centos 7

How reproducible:


Steps to Reproduce:
1. start a container with pid=host and command libvirtd
2. launch a qemu process using virsh in the container. The start qemu process will be unattached.
3. try to kill the container using `docker kill -s KILL <container_id>

Actual results:

the qemu process is killed, too.

Expected results:

the unattached qemu process is not killed.


Additional info:
Comment 2 Daniel Walsh 2016-02-22 14:37:28 EST
Turns out this is a bug in the testing environment.

Note You need to log in before you can comment on or make changes to this bug.