Bug 1302817 - rhn-satellite-exporter is using broken queries for --whole-errata option
rhn-satellite-exporter is using broken queries for --whole-errata option
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Radovan Drazny
:
: 863093 (view as bug list)
Depends On:
Blocks: sat570-triage
  Show dependency treegraph
 
Reported: 2016-01-28 12:03 EST by Jan Dobes
Modified: 2016-08-02 08:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.3.3-35-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 09:51:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Dobes 2016-01-28 12:03:47 EST
Description of problem:
When running rhn-satellite-exporter with --start-date, --end-date and --whole-errata parameters, there are various issues.

1. When exporting with --use-sync-date parameter, rhn-satellite-exporter crashes.
2. When exporting with --use-rhn-date parameter (or none parameter), package ids without any errata are not included in channel XML, even the packages themselves XMLs are included in package directory.

Version-Release number of selected component (if applicable):
spacewalk-backend-2.3.3-33.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Have custom channel with errata and packages, and some packages without relevant errata.
2. Experiment with rhn-satellite-exporter with parameters described above.

Actual results:
results described above

Expected results:
no crashes, even packages without related errata are exported
Comment 1 Jan Dobes 2016-01-28 12:14:26 EST
fixed in spacewalk master:

0455d0877eebbed84d7a6dcfed5adab4a754095d
e7346ca9b385e1a5913299cd9983b6d2cddb67fa
Comment 4 Jan Dobes 2016-02-19 05:05:53 EST
*** Bug 863093 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2016-03-17 09:51:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0461.html

Note You need to log in before you can comment on or make changes to this bug.