Bug 1302818 - Updating the initscripts package to version initscripts-9.03.49-1.el6_7.3 introduced bug in ifdown-eth
Updating the initscripts package to version initscripts-9.03.49-1.el6_7.3 int...
Status: CLOSED DUPLICATE of bug 1300971
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.7
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 12:04 EST by Saul Serna
Modified: 2016-11-25 08:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 01:22:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saul Serna 2016-01-28 12:04:48 EST
Customer reported the following, possible initscript bug:


RHEL 6 x86_64 servers were patched. The initscripts package was updated to initscripts-9.03.49-1.el6_7.3.x86_64.  Following this update, an in house application failed to start and the ability to SSH to the server was lost. 

Investigation showed a bug in the /etc/sysconfig/network-scripts/ifdown-eth file similar to what was reported under https://bugs.centos.org/view.php?id=10095.

Editing line 110 of /etc/sysconfig/network-scripts/ifdown-eth from:

"if [ "${REALDEVICE}" = "${DEVICE}" ]; then" 

to 

"if [ "${REALDEVICE}" != "${DEVICE}" ]; then" 

and restarting the network service restored SSH access and the in house application was able to start normally.

Is this a reported bug for RHEL and package initscripts-9.03.49-1.el6_7.3?

The problem occurs after the initscripts package is updated to version initscripts-9.03.49-1.el6_7.3.
Comment 2 Lukáš Nykrýn 2016-01-29 01:22:16 EST
Already fixed in https://git.fedorahosted.org/cgit/initscripts.git/commit/?h=rhel6-branch&id=4b627a20f4cce74e00b8f28d135cbbf583e2fa87

*** This bug has been marked as a duplicate of bug 1300971 ***

Note You need to log in before you can comment on or make changes to this bug.