Bug 1302821 - Cannot start sssd after switching to non-root
Summary: Cannot start sssd after switching to non-root
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-28 17:23 UTC by Jakub Hrozek
Modified: 2020-05-02 18:18 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-0.1.alpha.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:15:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 3979 None closed Cannot start sssd after switching to non-root 2020-05-02 18:17:59 UTC
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Jakub Hrozek 2016-01-28 17:23:40 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2938

Reproducer:
* enable logging to files (and not to journald)
* start sssd as root ("user = root" in "[sssd]" section of sssd.conf
* start sssd as non-root ("user = sssd" in "[sssd]" section of sssd.conf

Comment 1 Jakub Hrozek 2016-02-23 21:05:03 UTC
Fixed upstream:
    master:
        211539459651cbfb0cb03c800ce876c20420a195
        74cc3797e311fd5dc12473678f499041ade7784f 
    sssd-1-13:
        9f1186e7be7ece4d2b9bbbe444d3fc42ab57b808
        cbb04b9439d73fff027e193093a49cdac3cdb499

Comment 2 Mike McCune 2016-03-28 23:37:25 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 10 errata-xmlrpc 2016-11-04 07:15:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.