Bug 1302827 - Hooks can remain set after a stack operation is stopped
Hooks can remain set after a stack operation is stopped
Status: CLOSED DUPLICATE of bug 1302828
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z4
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 13:03 EST by Zane Bitter
Modified: 2016-04-26 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 13:06:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1538733 None None None 2016-01-28 13:03 EST

  None (edit)
Description Zane Bitter 2016-01-28 13:03:19 EST
If a thread is cancelled (including if heat-engine is restarted) while a user hook (aka breakpoint) is active, the hook is still marked as active in the database. If the user modifies the environment to disable the hook, then the next time Heat reaches the point in traversing the stack where the hook was invoked Heat will pause and wait for the hook to be cleared; however there will be no log message to indicate that the hook was invoked, nor a corresponding event in the event list, nor any indication from the "hook-poll" command that the hook is active.
Comment 1 Zane Bitter 2016-01-28 13:06:46 EST

*** This bug has been marked as a duplicate of bug 1302828 ***

Note You need to log in before you can comment on or make changes to this bug.