Bug 1302834 - Backport validation of filters in snapshot*, backup* in db.api in OSP6
Backport validation of filters in snapshot*, backup* in db.api in OSP6
Status: CLOSED DUPLICATE of bug 1288654
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
6.0 (Juno)
All Linux
unspecified Severity medium
: ---
: 6.0 (Juno)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 13:22 EST by Jaison Raju
Modified: 2016-04-26 17:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 04:22:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaison Raju 2016-01-28 13:22:08 EST
Description of problem:
Validation of filters in snapshot*, backup* in db.api needs to be done in OSP6
Some more details on my issue:
Cinder
2016-01-28 14:43:50.941 3126 TRACE cinder.api.middleware.fault InvalidRequestError: Entity '<class 'cinder.db.sqlalchemy.models.Snapshot'>' has no property 'tenant_id'

Horizon
Thu Jan 28 03:43:50.945988 2016] [:error] [pid 3356] ClientException: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-bf612a1a-cf72-4396-be9b-756e491e991b)
This is fixed in liberty 7.0.0:
https://review.openstack.org/#/c/217110/
This patch needs to be backported to OSP6.

Version-Release number of selected component (if applicable):
RHOS6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Sergey Gotliv 2016-01-28 16:27:21 EST
Matthias,

Please, read this BZ. I believe we agreed in the past that Horizon should use correct filters, I just don't remember if you've backported the relevant Horizon patch fixing that problem.

I don't like the idea that Cinder ignores wrong filters instead of throwing an error in Liberty, but if you didn't fix that BZ in Horizon yet then I'll definitely proceed with the Cinder backport [1] to OSP 6.0.

[1] https://review.openstack.org/#/c/217110/
Comment 3 Matthias Runge 2016-01-28 16:40:19 EST
Sergey, I don't know if we agreed on this patch[1], since I don't know the impact of that on cinder, but I have backported a fix[2] for horizon, on which we agreed. Form looking at the stack trace, it could be the same bug. like [3].
If I find some time tomorrow, I'll issue a build.

[2] https://code.engineering.redhat.com/gerrit/#/c/65755/
[3] https://bugzilla.redhat.com/show_bug.cgi?id=1288654
Comment 7 Sergey Gotliv 2016-02-15 01:21:29 EST
(In reply to Matthias Runge from comment #3)
> Sergey, I don't know if we agreed on this patch[1], since I don't know the
> impact of that on cinder, but I have backported a fix[2] for horizon, on
> which we agreed. Form looking at the stack trace, it could be the same bug.
> like [3].
> If I find some time tomorrow, I'll issue a build.

Matthias, thanks for the quick response and the horizon build! I have to take another look if it fixes the problem described here. The idea is the same, we have to use correct filters instead of validating them, but it seems that patch below fixes volumes' filters only while this issue seems reports issues with snapshots and backups. 

> 
> [2] https://code.engineering.redhat.com/gerrit/#/c/65755/
> [3] https://bugzilla.redhat.com/show_bug.cgi?id=1288654
Comment 10 Sergey Gotliv 2016-02-16 01:53:46 EST
Please, reassign to Cinder if Horizon build in comment#6 doesn't fix the problem.
Comment 16 Matthias Runge 2016-03-04 04:22:24 EST

*** This bug has been marked as a duplicate of bug 1288654 ***

Note You need to log in before you can comment on or make changes to this bug.