Bug 1302838 - Disable start button for terminated ec2 instances
Disable start button for terminated ec2 instances
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: lgalis
Pavol Kotvan
: ZStream
Depends On: 1302410
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 13:28 EST by John Prause
Modified: 2016-04-13 14:42 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302410
Environment:
Last Closed: 2016-04-13 14:42:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of terminated instance summary page before fix (153.02 KB, image/png)
2016-04-11 13:47 EDT, Nandini Chandra
no flags Details
screenshot of terminated instance summary page after fix (150.82 KB, image/png)
2016-04-11 13:48 EDT, Nandini Chandra
no flags Details

  None (edit)
Comment 2 CFME Bot 2016-03-15 17:04:06 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4e7fc09b9a347395120d8faea56367fa5bbcf159

commit 4e7fc09b9a347395120d8faea56367fa5bbcf159
Merge: c696303 7d64de7
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Mar 15 16:40:57 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Mar 15 16:40:57 2016 -0400

    Merge branch '5.5.z_start_button_enabled_for_terminated_instances' into '5.5.z'
    
    5.5.z start button enabled for terminated instances
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302838
    
    cherry pick from https://github.com/ManageIQ/manageiq/pull/6475
    the specs had to be updated for 5.5
    
    See merge request !853

 app/helpers/application_helper/toolbar_builder.rb       |  2 ++
 app/models/vm_or_template.rb                            |  4 ++++
 app/models/vm_or_template/operations.rb                 |  6 ++++++
 spec/helpers/application_helper/toolbar_builder_spec.rb | 10 ++++++++++
 4 files changed, 22 insertions(+)
Comment 6 lgalis 2016-03-29 08:39:35 EDT
The state is 'off' not 'terminated'. This BZ only removes the Start button for instances in the 'Terminated' state
Comment 12 Nandini Chandra 2016-04-11 13:45:59 EDT
Hi Pavol,

Yes, the steps are accurate.

I have attached a screen shot of the summary page of a terminated instance before the fix(5.5.2.4) and after the fix(5.5.3.4).

After the fix:
1)Instance summary page shows that the instance is terminated
2)Instance is archived immediately
3)Archived Instance summary page doesn't show Power button(and hence no Start button).

Marking this BZ as VERIFIED.

Verified in 5.5.3.4
Comment 13 Nandini Chandra 2016-04-11 13:47 EDT
Created attachment 1146072 [details]
Screenshot of terminated instance summary page before fix
Comment 14 Nandini Chandra 2016-04-11 13:48 EDT
Created attachment 1146073 [details]
screenshot of terminated instance summary page after fix
Comment 16 errata-xmlrpc 2016-04-13 14:42:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.