Bug 130287 - usermod will not add NIS users to locally defined groups in /etc/group
usermod will not add NIS users to locally defined groups in /etc/group
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 16:24 EDT by Eric Paris
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 05:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2004-08-18 16:24:08 EDT
Description of problem:
We wish to be able to use usermod to add a NIS user to a group defined
locally on a single machine in the /etc/group file.  Currently usermod
just returns an error because the user is not defined in /etc/passwd.
 This works just fine if the /etc/group file is edited by hand to
include the nis user.  Its just the usermod tool that refused to
create the entry.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-20

How reproducible:
Always

Steps to Reproduce:
1.create a nis user: nis_user
2.create a local group: local_group
3.run "usermod -G local_group nis_user"
    

Actual Results:  User is not added to the local group.  Usermod
returns with the error

usermod: nis_user not found in /etc/passwd

Expected Results:  I would expect a line such as 
local_group:x:105:nis_user
to appear in the /etc/group file

Additional info:
Comment 3 Peter Vrabec 2005-04-11 05:08:50 EDT
You must make any changes involving NIS on the NIS server
(man usermod)

U can use "gpasswd -a nis_user local_group" instead of "usermod -G local_group
nis_user"

Note You need to log in before you can comment on or make changes to this bug.