Bug 1302907 - Correctly set MTU on vovsbr and vlinuxbr
Correctly set MTU on vovsbr and vlinuxbr
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Winship
Meng Bo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 18:34 EST by Eric Jones
Modified: 2016-06-28 10:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift 3.1
Last Closed: 2016-02-29 11:39:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2016-01-28 18:34:17 EST
- What is the nature and description of the request?  
As an admin I need the ability to easily configure the MTU for the cluster.

- Why does the customer need this? (List the business requirements here)  
Certain platforms that can host OSE (AWS) have the ability to use higher than normal MTUs (8951), which required manually adding a few specific settings into the system/multi-user.target.wants/atomic-openshift-node.service

- How would the customer like to achieve this? (List the functional requirements here)  
Add a tool that adds these settings for the admin

- Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Not that I could find  

- List any affected packages or components.  
OpenShift
Networking
Comment 4 Eric Paris 2016-02-15 10:03:35 EST
os-sdn pr merged
Comment 5 Dan Winship 2016-02-16 16:07:18 EST
origin PR merged (https://github.com/openshift/origin/pull/7310)
Comment 6 Dan Winship 2016-02-18 10:16:58 EST
This is now in OSE
Comment 7 Yan Du 2016-02-22 02:37:51 EST
Test on latest OSE env, bug have been fixed.


[root@node1 ~]# ifconfig | grep -i mtu
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
lbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
tun0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
vlinuxbr: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
vovsbr: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

Add following settings to atomic-openshift-node.service

ExecStartPost=/usr/bin/sleep 10
ExecStartPost=/usr/sbin/ip link set dev vovsbr mtu 8951
ExecStartPost=/usr/sbin/ip link set dev vlinuxbr mtu 8951


[root@node1 ~]# systemctl stop atomic-openshift-node
[root@node1 ~]# systemctl start atomic-openshift-node

[root@node1 ~]# ifconfig | grep -i mtu
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
lbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 8951
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
tun0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 8951
vlinuxbr: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 8951
vovsbr: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 8951
Comment 8 Yan Du 2016-02-22 22:17:08 EST
Change the mtu settings in node-config.yaml, it will take effect too.

networkConfig:
   mtu: 3450

Delete lbr0 then restart openshift-node

[root@node1 ~]# ip a | grep mtu
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
5: br0: <BROADCAST,MULTICAST> mtu 3450 qdisc noop state DOWN 
385: lbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 3450 qdisc noqueue state UP 
386: vovsbr@vlinuxbr: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 3450 qdisc pfifo_fast master ovs-system state UP 
387: vlinuxbr@vovsbr: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 3450 qdisc pfifo_fast master lbr0 state UP 
388: tun0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 3450 qdisc noqueue state UNKNOWN
Comment 10 errata-xmlrpc 2016-02-29 11:39:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0320

Note You need to log in before you can comment on or make changes to this bug.