Bug 1302917 - easystroke FTBFS in rawhide
easystroke FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: easystroke (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 19:27 EST by Jonathan Wakely
Modified: 2016-02-01 12:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 12:31:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2016-01-28 19:27:02 EST
It needs to be rebuilt with the new Boost 1.60.0 package.

Before gcc-6.0.0 arrived in rawhide it failed to build because it depends on libsigc++ which now requires C++11, but gcc-6 defaults to C++14 so that is resolved, and it fails with this error instead:

actions.cc: In constructor 'TreeViewMulti::TreeViewMulti()':
actions.cc:57:39: error: 'group' is not a member of 'sigc'
  get_selection()->set_select_function(sigc::group(&negate, sigc::ref(pending)));
                                       ^~~~
Comment 1 Tom "spot" Callaway 2016-02-01 12:31:09 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.