Bug 1302919 - Fedora-easy-karma imports yum (causing a deprecation warning) if python2-dnf is not installed
Fedora-easy-karma imports yum (causing a deprecation warning) if python2-dnf ...
Status: CLOSED DUPLICATE of bug 1270600
Product: Fedora
Classification: Fedora
Component: fedora-easy-karma (Show other bugs)
23
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 19:32 EST by Francisco Villavicencio
Modified: 2016-03-25 04:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-25 04:47:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco Villavicencio 2016-01-28 19:32:56 EST
Description of problem: When running fedora-easy-karma on f23 there is a message;

Line 47 import yum.

This bug was reported on october 2015, but until now January 28 2016 is still there. Who is suppossed to fix that bug?

I'm trying to run the test on fedora 23 but I'm stuck at this point.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2016-01-28 20:21:46 EST
This will only happen if you don't have python2-dnf installed. It's not a hard dependency because f-e-k *can* function with yum, if python2-dnf isn't available. I'm not sure whether it's really worth calling this a bug, exactly, it's kind of a subjective decision on the packager's part whether to 'enforce' use of python2-dnf for F23 users.
Comment 2 Yu Watanabe 2016-03-17 04:14:30 EDT
I think in the spec file, f-e-k should requires python2-dnf.
If the system is installed, for example,

# dnf --releasever=23 --installroot=/newsysroot \
      install '@core' fedora-easy-karma

then, in the installed system, f-e-k output the following error message.
====================================
Traceback (most recent call last):
  File "/usr/bin/fedora-easy-karma", line 47, in <module>
    import yum
ImportError: No module named yum
====================================

Because, the above dnf command installs python3-dnf, not python2-dnf.
Comment 3 Till Maas 2016-03-25 04:47:35 EDT
Thank you for the report, the current package in testing recommends python2-dnf, see bug 1270600 for this.

*** This bug has been marked as a duplicate of bug 1270600 ***

Note You need to log in before you can comment on or make changes to this bug.