Bug 130298 - [PATCH] mkinitrd 3.5.24 always uses /sys (even at kernel 2.4)
Summary: [PATCH] mkinitrd 3.5.24 always uses /sys (even at kernel 2.4)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-18 21:27 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.1.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 15:46:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd-3.5.24-kernel26.patch (1.22 KB, patch)
2004-08-18 21:29 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2004-08-18 21:27:53 UTC
Description of problem:
As talked per e-mail with you, I'm tracking down "my issue" and the 
corresponding patch in this bug report here, that the information 
isn't lost.

mkinitrd 3.5.24 always creates and tries to use /sys - even at 
kernel 2.4 and causes harmless but unnecessary error messages at 
booting time, so I worked out a patch that fixes the issue for me.

Version-Release number of selected component (if applicable):
mkinitrd-3.5.24-1

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Install mkinitrd 3.5.24 at FC1 or RHEL3
2. Install a new 2.4 kernel or recreate the mkinitrd
3. Reboot the machine and have a look to the booting messages
  
Actual results:
Patch is attached.

Expected results:
Fix at some time like I did it or better ;-)

Additional info:
This patch seems to be only for belong for the older (even aliving) 
3.5.x line.

Comment 1 Robert Scheck 2004-08-18 21:29:15 UTC
Created attachment 102859 [details]
mkinitrd-3.5.24-kernel26.patch

Comment 2 Jeremy Katz 2004-08-19 15:46:24 UTC
Done slightly differently, but the basic idea is there in cvs now


Note You need to log in before you can comment on or make changes to this bug.