Bug 1303017 - [Gtk 3.20] Edit boxes are wrongly formatted
[Gtk 3.20] Edit boxes are wrongly formatted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 05:12 EST by Vít Ondruch
Modified: 2016-05-12 06:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: firefox-45.0.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 06:08:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Bugzilla (148.61 KB, image/png)
2016-01-29 05:12 EST, Vít Ondruch
no flags Details
firefox-45.0.1-2.fc25.x86_64 (117.92 KB, image/png)
2016-03-23 05:47 EDT, Vít Ondruch
no flags Details
tin-cup.net (99.80 KB, image/png)
2016-03-23 05:50 EDT, Vít Ondruch
no flags Details

  None (edit)
Description Vít Ondruch 2016-01-29 05:12:31 EST
Created attachment 1119391 [details]
Screenshot of Bugzilla

Description of problem:
With FF 44, the edit boxes has wrong format. As you can see in BZ, there is some strange padding of text on the right/left side, while the box is not high enough to properly accommodate the text (diacritics is unreadable).


Version-Release number of selected component (if applicable):
$ rpm -q firefox
firefox-44.0-3.fc24.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This might be once again related to some Gtk3 changes, but I don't remember to see this issues with F43 ... Actually, writing this issue, it seems that this applies also to text box, where the scroll bars are misaligned.
Comment 1 Martin Stransky 2016-01-29 05:14:52 EST
Yes that's because Gtk3 update in Fedora 24. I'm going to fix all those bugs when the Gtk3 update is complete and we have a final 3.20 release there.
Comment 2 Jan Kurik 2016-02-24 09:21:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Vít Ondruch 2016-03-14 08:12:08 EDT
(In reply to Martin Stransky from comment #1)
> Yes that's because Gtk3 update in Fedora 24. I'm going to fix all those bugs
> when the Gtk3 update is complete and we have a final 3.20 release there.

Any update on this? GTK should be in freeze now, so no other breakage should happen (yes, I know, that might be just theory ;))
Comment 4 Martin Stransky 2016-03-22 04:51:08 EDT
firefox-45.0.1-2.fc24 fixes that.
Comment 5 Martin Stransky 2016-03-22 04:58:24 EDT
The update is here - https://bodhi.fedoraproject.org/updates/FEDORA-2016-44d7ec40fd
Comment 6 Vít Ondruch 2016-03-22 08:20:32 EDT
This is not fixed for me:

$ rpm -q firefox 
firefox-45.0.1-2.fc25.x86_64

$ rpm -q gtk3
gtk3-3.19.12-1.fc25.x86_64

Actually I upgraded to

$ rpm -q gtk3
gtk3-3.20.0-1.fc25.x86_64

and still nothing.
Comment 7 Martin Stransky 2016-03-22 08:27:56 EDT
Have you restarted your browser completely? Can you please attach a screenshot? Which DE do you run?
Comment 8 Vít Ondruch 2016-03-23 05:47 EDT
Created attachment 1139439 [details]
firefox-45.0.1-2.fc25.x86_64

Sure I restarted FF, even the whole computer.

On the SS, you can notice, that the edit boxed are probably higher and wider the they should and that the scollbar of the text box is completely misplaced.
Comment 9 Vít Ondruch 2016-03-23 05:50 EDT
Created attachment 1139440 [details]
tin-cup.net

On this SS, you can see again the edit boxes, which have much wider margin/padding (whatever it is) then they should have.

Also, the "fairway" combos are gray, while they should be white ... and there is no border, not sure if there should be any, though :)
Comment 10 Martin Stransky 2016-03-23 06:18:51 EDT
The size of entries is correct - compare it with gtk3-widget-factory.
Comment 11 Vít Ondruch 2016-03-23 06:53:31 EDT
Well, cannot comment on this, since I don't really understand what it means or what are the implications, but if you take a look at the BZ SS, you can see that the "Summary", which has custom color and border, is not that high as the unstyled "Bug Id" edit box. I am pretty sure that the intention of the author was to have the sizes the same and up until the Gtk 3.18, it was always the same height.
Comment 12 Martin Stransky 2016-03-23 07:01:09 EDT
The "Summary" on your screenshot uses "-moz-appearance" css style which means that firefox use an intenal widget rendering instead of the styled (system) ones. Don't ask me why bugzilla author choose to use such style for some entries and default (styled) for another.
Comment 13 Vít Ondruch 2016-03-23 07:42:32 EDT
IOW you say this if web page design fault.

But what about the scrollbar in the "addition comments" field? It is completely misplaced IMO.
Comment 14 Martin Stransky 2016-05-12 06:08:06 EDT
The scrollbar position is fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1263145 which is completely different bug.

Note You need to log in before you can comment on or make changes to this bug.