Bug 1303023 - missing result="" attribute on <result/> element in job results XML
missing result="" attribute on <result/> element in job results XML
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: reports (Show other bugs)
22
Unspecified Unspecified
urgent Severity urgent (vote)
: 22.1
: ---
Assigned To: Dan Callaghan
matt jia
: Patch, Regression, TestBlocker
Depends On:
Blocks: 1303004
  Show dependency treegraph
 
Reported: 2016-01-29 05:38 EST by Ales Zelinka
Modified: 2016-01-31 23:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 23:30:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2016-01-29 05:38:21 EST
Description of problem:

result element no longer has result attribute. We rely on this in out tooling (tcms-results). This change breaks all beaker regression testing.


Details by xzhou@redhat.com:

> One attribute "result" has gone.
> 
> -<result id="184817448" path="/start" result="Pass" score="0.00">Install Started</result>
> +<result id="184817448" path="/start" score="0.00">Install Started</result>



Version-Release number of selected component (if applicable):
22.0
Comment 1 Dan Callaghan 2016-01-31 17:47:43 EST
So it turns out our test coverage for job results XML is not very thorough, which in hindsight is obviously quite a serious problem.

However I have compared the results XML output from release-21 branch vs. release-22 branch and this missing result="" attribute is the only issue I can see.
Comment 2 Dan Callaghan 2016-01-31 18:10:51 EST
http://gerrit.beaker-project.org/4648
Comment 3 Dan Callaghan 2016-01-31 18:11:15 EST
I am going to add some more complete test cases for the job results XML too but I don't want to hold up this fix for those.
Comment 4 Dan Callaghan 2016-01-31 20:17:37 EST
(In reply to Dan Callaghan from comment #3)
> I am going to add some more complete test cases for the job results XML too
> but I don't want to hold up this fix for those.

http://gerrit.beaker-project.org/4649
Comment 6 matt jia 2016-01-31 23:03:02 EST
Steps to verify:

1. look at one completed job results XML.

2. It contains the <result> element.
Comment 7 matt jia 2016-01-31 23:08:33 EST
(In reply to matt jia from comment #6)
> Steps to verify:
> 
> 1. look at one completed job results XML.
> 
> 2. It contains the <result> element.

To be more specially, the missing result attribute has been added back to the <result> element.
Comment 8 Dan Callaghan 2016-01-31 23:30:32 EST
Beaker 22.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.