Bug 1303043 - ipa-server-install failed due to client side configuration on master server
ipa-server-install failed due to client side configuration on master server
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 07:00 EST by Abhijeet Kasurde
Modified: 2016-02-08 07:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 07:02:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (8.00 KB, text/plain)
2016-01-29 07:00 EST, Abhijeet Kasurde
no flags Details
httpd_error_log (1.31 KB, text/plain)
2016-01-29 07:01 EST, Abhijeet Kasurde
no flags Details
Trace_back (4.22 KB, text/plain)
2016-01-29 07:01 EST, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2016-01-29 07:00:44 EST
Created attachment 1119402 [details]
console.log

Description of problem:
ipa-server-install failed due to failed client side configuration on master server. This is caused to permission issue following is excerpt of httpd error_log

[Fri Jan 29 15:41:21.929220 2016] [:error] [pid 24498] The following error occurred while trying to extract file(s) to the Python egg
[Fri Jan 29 15:41:21.929222 2016] [:error] [pid 24498] cache:
[Fri Jan 29 15:41:21.929224 2016] [:error] [pid 24498]
[Fri Jan 29 15:41:21.929226 2016] [:error] [pid 24498]   [Errno 13] Permission denied: '/usr/share/httpd/.python-eggs'
[Fri Jan 29 15:41:21.929228 2016] [:error] [pid 24498]
[Fri Jan 29 15:41:21.929230 2016] [:error] [pid 24498] The Python egg cache directory is currently set to:
[Fri Jan 29 15:41:21.929232 2016] [:error] [pid 24498]
[Fri Jan 29 15:41:21.929233 2016] [:error] [pid 24498]   /usr/share/httpd/.python-eggs
[Fri Jan 29 15:41:21.929235 2016] [:error] [pid 24498]
[Fri Jan 29 15:41:21.929237 2016] [:error] [pid 24498] Perhaps your account does not have write access to this directory?  You can
[Fri Jan 29 15:41:21.929239 2016] [:error] [pid 24498] change the cache directory by setting the PYTHON_EGG_CACHE environment
[Fri Jan 29 15:41:21.929241 2016] [:error] [pid 24498] variable to point to an accessible directory.
[Fri Jan 29 15:41:21.929243 2016] [:error] [pid 24498]
[Fri Jan 29 15:41:24.421798 2016] [:error] [pid 24497] [remote 10.65.201.167:120] mod_wsgi (pid=24497): Target WSGI script '/usr/share/ipa/wsgi.py' does not contain WSGI application 'application'.



Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7_2.5.x86_64

How reproducible:
I think this is something machine specific / setup specific issue.

Actual results:
Installation fails with error "Configuration of client side components failed!"

Expected results:
Installation should succeed
Comment 1 Abhijeet Kasurde 2016-01-29 07:01 EST
Created attachment 1119403 [details]
httpd_error_log
Comment 2 Abhijeet Kasurde 2016-01-29 07:01 EST
Created attachment 1119405 [details]
Trace_back
Comment 4 Petr Vobornik 2016-01-29 07:35:00 EST
I'm unable to reproduce with ipa-server-4.2.0-15.el7_2.5.x86_6

There is probably some custom httpd configuration or package. 

Could you attach httpd/error_log from beginning of IPA server installation and earlier if there is something. 

Same with ipaserver-install.log.
Comment 5 Abhijeet Kasurde 2016-02-08 07:02:03 EST
Unable to reproduce with fresh build. Closing issue.

Note You need to log in before you can comment on or make changes to this bug.