Bug 1303076 - Rebase samba in RHEL-7.3 to version 4.4.x
Rebase samba in RHEL-7.3 to version 4.4.x
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
Robin Hack
Marc Muehlfeld
: Rebase
Depends On: 1320230 1320247 1320252 1320253 1344672
Blocks: 1296125 1313485
  Show dependency treegraph
 
Reported: 2016-01-29 08:30 EST by Sumit Bose
Modified: 2017-02-06 03:45 EST (History)
9 users (show)

See Also:
Fixed In Version: samba-4.4.4-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_samba_ rebased to version 4.4.4 The _samba_ packages have been upgraded to upstream version 4.4.4, which provides a number of bug fixes and enhancements over the previous version: * The WINS nsswitch module now uses the *libwbclient* library for WINS queries. Note that the "winbind" daemon must be running to resolve WINS names that use the module. * The default value of the "winbind expand groups" option has been changed from "1" to "0". * The "-u" and "-g" options of the "smbget" command have been replaced with the "-U" option to match other Samba command's parameter. The "-U" option accepts a "username[%password]" value. Additionally, the "username" and "password" parameters in the "smbgetrc" configuration file have been replaced with the "user" parameter. * The "-P" parameter of the "smbget" command has been removed. * Printing using the "CUPS" back end with Kerberos credentials now requires to install the _samba-krb5-printing_ package and to configure CUPS appropriately. * It is now possible to configure Samba as a print server by using the CUPS back end with Kerberos credentials. To do so, install the _samba-krb5-printing_ package and configure CUPS appropriately. * Samba and CTDB header files are no longer installed automatically when you install _samba_. Samba automatically updates its tdb database files when the "smbd", "nmbd", or "winbind" daemon starts. Back up the databases files before starting Samba. Note that Red Hat does not support downgrading tdb database files. Note that using the Linux kernel CIFS module with SMB protocol 3.1.1 is currently experimental and the functionality is unavailable in kernels provided by Red Hat. For further information about notable changes, read the upstream release notes before updating: * https://www.samba.org/samba/history/samba-4.3.0.html * https://www.samba.org/samba/history/samba-4.4.0.html
Story Points: ---
Clone Of:
: 1355736 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:59:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2468 normal SHIPPED_LIVE samba bug fix and enhancement update 2016-11-03 10:06:51 EDT

  None (edit)
Description Sumit Bose 2016-01-29 08:30:07 EST
Besides including all the latest upstream bugfixes and interoperability improvements the new Samba version contains e.g a GnuTLS based backupkey implementation which integrates Samba better with the systems crypto libraries instead of doing the crypto on its own.

Newer file-server feature might be meeded by the storage team in one of their upcoming products.
Comment 4 Andreas Schneider 2016-03-11 04:23:13 EST
winbindd does not list group memberships for display purposes (e.g. getent group ) anymore by default in Samba 4.2.0 and newer.

The new default is "winbind expand groups = 0" now, the reason for this is the same as for "winbind enum users = no" and "winbind enum groups = no". Providing this information is not always reliably possible, e.g. if there are trusted domains.
Comment 5 Andreas Schneider 2016-03-11 04:25:36 EST
smbget
------
The -u and -p options for user and password were replaced by the -U option that
accepts username[%password] as in many other tools of the Samba suite.
Similary, smbgetrc files do not accept username and password options any more,
only a single "user" option which also accepts user%password combinations.
The -P option was removed.
Comment 6 Andreas Schneider 2016-03-11 04:26:16 EST
WINS nsswitch module
--------------------

The WINS nsswitch module has been rewritten to address memory issues and to
simplify the code. The module now uses libwbclient to do WINS queries. This
means that winbind needs to be running in order to resolve WINS names using
the nss_wins module. This does not affect smbd.
Comment 7 Martin Kosek 2016-06-07 08:28:10 EDT
For the record, the current plan is to rebase to Samba 4.4.4 (released today):
https://www.samba.org/samba/history/samba-4.4.4.html
Comment 8 Andreas Schneider 2016-06-08 05:14:51 EDT
smbspool_krb5_wrapper
---------------------

To be able to print with CUPS using Kerberos credentials you need to install the samba-krb5-printing package and configure CUPS appropriately.
Comment 9 Andreas Schneider 2016-06-08 05:26:29 EDT
As with every Samba release, upgrades of tdb files are supported but not downgrades. Customers need to backup tdb files. Check earlier releases for the text.
Comment 11 Andreas Schneider 2016-06-20 07:06:34 EDT
Public headers
--------------

Several public headers are not installed any longer. They are made for internal
use only. More public headers will very likely be removed in future releases.

Also public CTDB header files are no longer installed, since Samba and CTDB are built from within the same source tree.
Comment 16 Robin Hack 2016-10-03 07:47:45 EDT
We know about some regressions but they will be documented. 

VERFIED as part of qa process.
Comment 18 errata-xmlrpc 2016-11-04 02:59:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2468.html

Note You need to log in before you can comment on or make changes to this bug.